diff options
author | xiota | 2023-11-28 02:28:53 -0800 |
---|---|---|
committer | xiota | 2023-11-28 02:29:21 -0800 |
commit | baf4c7e4c6a2424442d675daaca8ba362ef24ad0 (patch) | |
tree | cbff9aaca8da23ba3e88d8b4556e1eef1e875c46 | |
parent | 7ce0dbda211c139f30acd1ad594284adebef9b76 (diff) | |
download | aur-baf4c7e4c6a2424442d675daaca8ba362ef24ad0.tar.gz |
fix build
-rw-r--r-- | .SRCINFO | 8 | ||||
-rw-r--r-- | .gitignore | 8 | ||||
-rw-r--r-- | PKGBUILD | 55 |
3 files changed, 50 insertions, 21 deletions
@@ -1,14 +1,16 @@ pkgbase = mapbox-gl-qml pkgdesc = Mapbox GL Native bindings for Qt QML pkgver = 2.1.1 - pkgrel = 1 + pkgrel = 2 url = https://github.com/rinigus/mapbox-gl-qml arch = x86_64 arch = aarch64 license = LGPL3 - depends = mapbox-gl-native + makedepends = cmake + depends = maplibre-native depends = qt5-location + depends = qt5-svg source = mapbox-gl-qml-2.1.1.tar.gz::https://github.com/rinigus/mapbox-gl-qml/archive/refs/tags/2.1.1.tar.gz - b2sums = 0d9495767e300889521d3fe0f8d4caa36cfcc02a25279a078f6b71e2041d3a8b14c52f0e89f42a3c95d6e311aea761d214cc50cd820f335632faea495f08ed2f + sha256sums = 1a5e3369832e5d71b13db42d86cfd24ffe4573f8a8732fda6fea3e05a3417d43 pkgname = mapbox-gl-qml diff --git a/.gitignore b/.gitignore index 713f6f80aff8..018a3de08144 100644 --- a/.gitignore +++ b/.gitignore @@ -1,4 +1,4 @@ -/* -!/.gitignore -!/.SRCINFO -!/PKGBUILD +* +!PKGBUILD +!.SRCINFO +!.gitignore @@ -1,23 +1,50 @@ -pkgname=mapbox-gl-qml +# Maintainer: + +_pkgname="mapbox-gl-qml" +pkgname="$_pkgname${_pkgtype:+-$_pkgtype}" pkgver=2.1.1 -pkgrel=1 +pkgrel=2 pkgdesc="Mapbox GL Native bindings for Qt QML" -arch=(x86_64 aarch64) -url="https://github.com/rinigus/$pkgname" +url="https://github.com/rinigus/mapbox-gl-qml" license=(LGPL3) -depends=(mapbox-gl-native qt5-location) -source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz") -b2sums=('0d9495767e300889521d3fe0f8d4caa36cfcc02a25279a078f6b71e2041d3a8b14c52f0e89f42a3c95d6e311aea761d214cc50cd820f335632faea495f08ed2f') +arch=(x86_64 aarch64) + +depends=( + 'maplibre-native' + 'qt5-location' + 'qt5-svg' +) +makedepends=( + 'cmake' +) + +_pkgsrc="$_pkgname-$pkgver" +_pkgext="tar.gz" +source=( + "$_pkgsrc.$_pkgext"::"$url/archive/refs/tags/$pkgver.$_pkgext" +) +sha256sums=( + '1a5e3369832e5d71b13db42d86cfd24ffe4573f8a8732fda6fea3e05a3417d43' +) + build() { - cmake -B build -S $pkgname-$pkgver \ - -DCMAKE_INSTALL_PREFIX='/usr' \ - -DCMAKE_BUILD_TYPE=None \ - -DCMAKE_INSTALL_LIBDIR=lib \ - -DUSE_CURL_SSL=OFF - cmake --build build + local _cmake_options=( + -B build + -S "$_pkgsrc" + -DCMAKE_BUILD_TYPE=None + -DCMAKE_INSTALL_PREFIX='/usr' + -DCMAKE_INSTALL_LIBDIR='lib' + + -DUSE_CURL_SSL=OFF + + -Wno-dev + ) + + cmake "${_cmake_options[@]}" + cmake --build build } package() { - make -C build DESTDIR="$pkgdir" install + DESTDIR="${pkgdir:?}" cmake --install build } |