summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuval Adam2015-06-30 15:51:17 +0300
committerYuval Adam2015-06-30 15:51:17 +0300
commita8a9076d2a59c886d40454169f64e34558ddc379 (patch)
treef8b375514ee83cf7b5922e80129087156355adc2
downloadaur-a8a9076d2a59c886d40454169f64e34558ddc379.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5f996229726
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mapbox-studio
+ pkgdesc = Vector tile driven map design
+ pkgver = 0.2.7
+ pkgrel = 1
+ url = https://mapbox.com/mapbox-studio/
+ arch = x86_64
+ license = BSD
+ makedepends = unzip
+ noextract = mapbox-studio-linux-x64-v0.2.7.zip
+ source = https://mapbox.s3.amazonaws.com/mapbox-studio/mapbox-studio-linux-x64-v0.2.7.zip
+ sha1sums = 671583b64167205ac6b1008f95e7176f53db897f
+
+pkgname = mapbox-studio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce98b8c6ed5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Yuval Adam <yuval at y3xz dot com> PGP-Key: 271386AA2EB7672F
+
+pkgname=mapbox-studio
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="Vector tile driven map design"
+arch=('x86_64')
+url="https://mapbox.com/mapbox-studio/"
+license=(BSD)
+depends=()
+makedepends=(unzip)
+source=("https://mapbox.s3.amazonaws.com/mapbox-studio/mapbox-studio-linux-x64-v${pkgver}.zip")
+noextract=("mapbox-studio-linux-x64-v${pkgver}.zip")
+sha1sums=('671583b64167205ac6b1008f95e7176f53db897f')
+
+prepare() {
+ unzip -q mapbox-studio-linux-x64-v${pkgver}.zip
+}
+
+package() {
+ install -dm755 "${pkgdir}/opt"
+ cp --preserve=mode -r "mapbox-studio-linux-x64-v${pkgver}" "${pkgdir}/opt/${pkgname}"
+ ln -s "${pkgdir}/opt/${pkgname}/atom" "${pkgdir}/opt/${pkgname}/mapbox-studio"
+}
+
+# vim:set ts=2 sw=2 et: