summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-10-02 19:56:39 +0200
committeroli2015-10-02 19:56:39 +0200
commitcb22900b28e450adb8170c919daeae79cd088f0e (patch)
tree981069fa59144a7b259745409911140bf5257971
downloadaur-cb22900b28e450adb8170c919daeae79cd088f0e.tar.gz
adopted and updated
-rw-r--r--.SRCINFO36
-rw-r--r--07_usrShareMapivi.diff160
-rw-r--r--08_removeMousePod.diff40
-rw-r--r--09_qw_parentheses.diff38
-rw-r--r--PKGBUILD44
-rwxr-xr-xmapivi14
-rw-r--r--mapivi.desktop12
-rw-r--r--mapivi.pngbin0 -> 1372 bytes
8 files changed, 344 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f6011dfeb47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = mapivi
+ pkgdesc = A photo management tool with focus on JPEG pictures. Mapivi supports adding, editing and searching of IPTC/IIM, EXIF data and JPEG comments. The pictures are managed in place (in your folder structure).
+ pkgver = 097
+ pkgrel = 1
+ url = http://mapivi.sourceforge.net/mapivi.shtml
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = jpegpixi
+ depends = jhead
+ depends = imagemagick
+ depends = libjpeg
+ depends = perl-image-info
+ depends = perl-image-metadata-jpeg
+ depends = tk-matchentry
+ depends = tk-resizebutton
+ depends = tk-splash
+ depends = perl-tk
+ depends = perl-exiftool
+ source = http://downloads.sourceforge.net/mapivi/mapivi097.tar.gz
+ source = mapivi
+ source = mapivi.desktop
+ source = mapivi.png
+ source = 07_usrShareMapivi.diff
+ source = 08_removeMousePod.diff
+ source = 09_qw_parentheses.diff
+ md5sums = f1432cbb0033c1a1a324651dbc0700b2
+ md5sums = 85f09ddc913d654ea92fa987838bcc63
+ md5sums = 5e34164357ee0351d68fd4ca048d99ac
+ md5sums = 15d8e83af7ccfa852774a48d2fb1ba75
+ md5sums = 59e1b327f32eea54e28463295f67496b
+ md5sums = 001918d8da9a54446df603e2c2804592
+ md5sums = 18937b9307fab48277499b76952439d0
+
+pkgname = mapivi
+
diff --git a/07_usrShareMapivi.diff b/07_usrShareMapivi.diff
new file mode 100644
index 000000000000..fb7d0312ae0b
--- /dev/null
+++ b/07_usrShareMapivi.diff
@@ -0,0 +1,160 @@
+--- mapivi.orig 2008-02-21 21:53:44.000000000 +0100
++++ mapivi 2009-03-16 16:50:53.000000000 +0100
+@@ -147,12 +147,13 @@
+ }
+ # for windows we use this path
+ $maprogsdir = $ENV{APPDATA}."/maprogs" if defined $ENV{APPDATA};
++my $usrshare = "/usr/share/mapivi"; # where static data is held
+ my $configdir = "$maprogsdir/mapivi"; # the configuration dir
+-my $icon_path = "$configdir/icons"; # the icon dir
++my $icon_path = "$usrshare/icons"; # the icon dir
+
+ my $splashAvail = (eval "require Tk::Splash") ? 1 : 0 ;
+ my $splash;
+-my $logo = "$configdir/logo.jpg";
++my $logo = "$usrshare/pics/logo.jpg";
+ if ($splashAvail and -f $logo) {
+ # Splash->Show parameters: $image, $width, $height, $title, $overrideredirect
+ $splash = Tk::Splash->Show($logo, 844, 259, "", 1);
+@@ -360,14 +361,14 @@
+ my $maxCommentLength = 2**16 - 3; # a comment block may have max 64kB
+
+ my $trashdir = "$configdir/trash"; # the trashcan
+-my $plugindir = "$configdir/PlugIns"; # the mapivi plugin dir
++my $plugindir = "$usrshare/PlugIns"; # the mapivi plugin dir
+ my $iptcdir = "$configdir/IPTC_templates"; # the IPTC templates folder
+ my $configFile = "$configdir/mapivirc"; # the configuration file
+ my $file_Entry_values = "$configdir/Entry_values";
+ my $exifdirname = ".exif"; # the subdir to store exif infos
+ my $thumbdirname = ".thumbs"; # the subdir to store thumbnails
+ my $xvpicsdirname = ".xvpics"; # a subdir from GIMP we usualy ignore
+-my $thumbExample = "$configdir/thumbExample.jpg";
++my $thumbExample = "$usrshare/pics/thumbExample.jpg";
+ my $nonJPEGsuffixes = "gif|png|tif|tiff|bmp|ppm|ps"; # xcf works, but makes problems with layers
+ my $cameraJunkSuffixes = "ctg"; # uninteresting files created by cameras
+ my $copyright_year = (localtime(time()))[5] + 1900; # the actual year, for the copyright notice
+@@ -544,7 +545,7 @@
+ "ColorThumbBG" => "azure3",
+ "ColorProgress" => "#106dba",
+ "ColorPicker" => "#efefef", # last color selected with color picker
+- "DefaultThumb" => "$configdir/EmptyThumb.jpg",
++ "DefaultThumb" => "$usrshare/pics/EmptyThumb.jpg",
+ "Copyright" => "copyright (c) $copyright_year Herrmann",
+ "Comment" => "This picture was taken in south africa ...",
+ "MaxProcs" => 1,
+@@ -677,7 +678,7 @@
+ "CopyFontColFG" => "white", # foreground color of the embedded copyright info font
+ "CopyFontColBG" => "black", # background color of the embedded copyright info font
+ "CopyFontShadow" => 1, # bool - add a shadow to the copyright text
+- "CopyrightLogo" => "$configdir/MapiviIcon.gif",
++ "CopyrightLogo" => "$usrshare/pics/MapiviIcon.gif",
+ "CopyTextOrLogo" => "text",
+ "BorderWidth1x" => 10, # border 1 width in x direction
+ "BorderWidth1y" => 10, # border 1 width in y direction
+@@ -845,7 +846,7 @@
+ 'AutoImport' => 1, # boolean = 1 start import at Mapivi wizard if memory card is inserted (ImportSource)
+ 'llWatermarkX' => 16, # lossless watermark x position
+ 'llWatermarkY' => -16, # lossless watermark y position
+- 'llWatermarkFile' => "$configdir/EmptyThumb.jpg", # lossless watermark file name
++ 'llWatermarkFile' => "$usrshare/pics/EmptyThumb.jpg", # lossless watermark file name
+ 'AspectBorderN' => 3, # lossless aspect ratio border
+ 'AspectBorderM' => 2, # lossless aspect ratio border
+ 'RelativeBorderX' => 10, # lossless relative border
+@@ -1083,14 +1084,14 @@
+ dKyyLnF00kjQlkTSR9GqxBKzyS6bEbY0EestAAEBADs=
+ EOF
+ my $mapiviicon = $top->Photo(-data => $icon_data);
+-my $mapiviiconfile = "$configdir/MapiviIcon.gif";
+-$mapiviiconfile = "$configdir/MapiviIcon32.gif" if $EvilOS;
++my $mapiviiconfile = "$usrshare/pics/MapiviIcon.gif";
++$mapiviiconfile = "$usrshare/pics/MapiviIcon32.gif" if $EvilOS;
+ #my $mapiviicon = $top->Photo(-file => $mapiviiconfile) if (-f $mapiviiconfile);
+ $top->idletasks if $EvilOS; # this line is crucial (at least on windows)
+ $top->iconimage($mapiviicon) if $mapiviicon;
+
+-my $dragAndDrop1 = "$configdir/MiniPic.jpg";
+-my $dragAndDrop2 = "$configdir/MiniPicMulti.jpg";
++my $dragAndDrop1 = "$usrshare/pics/MiniPic.jpg";
++my $dragAndDrop2 = "$usrshare/pics/MiniPicMulti.jpg";
+ my $dragAndDropIcon1 = $top->Photo(-file => $dragAndDrop1) if (-f $dragAndDrop1);
+ my $dragAndDropIcon2 = $top->Photo(-file => $dragAndDrop2) if (-f $dragAndDrop2);
+
+@@ -13682,10 +13683,10 @@
+ $help_menu->command(-image => compound_menu($top, 'About', 'dialog-information.png'), -command => \&about);
+ $help_menu->command(-image => compound_menu($top, 'Keys', 'input-keyboard.png'), -command => \&showkeys);
+ $help_menu->command(-image => compound_menu($top, 'System information', 'utilities-system-monitor.png'), -command => \&systemInfo);
+- $help_menu->command(-image => compound_menu($top, 'License', ''), -command => [\&showFile, "$configdir/License.txt"]) if (-f "$configdir/License.txt");
+- $help_menu->command(-image => compound_menu($top, 'History', ''), -command => [\&showFile, "$configdir/Changes.txt"]) if (-f "$configdir/Changes.txt");
+- $help_menu->command(-image => compound_menu($top, 'Tips', 'help-browser.png'), -command => sub { showFile("$configdir/Tips.txt") }) if (-f "$configdir/Tips.txt");
+- $help_menu->command(-image => compound_menu($top, 'FAQ', 'help-browser.png'), -command => [\&showFile, "$configdir/FAQ"]) if (-f "$configdir/FAQ");
++ $help_menu->command(-image => compound_menu($top, 'License', ''), -command => [\&showFile, "$usrshare/License.txt"]) if (-f "$usrshare/License.txt");
++ $help_menu->command(-image => compound_menu($top, 'History', ''), -command => [\&showFile, "$usrshare/Changes.txt"]) if (-f "$usrshare/Changes.txt");
++ $help_menu->command(-image => compound_menu($top, 'Tips', 'help-browser.png'), -command => sub { showFile("$usrshare/Tips.txt") }) if (-f "$usrshare/Tips.txt");
++ $help_menu->command(-image => compound_menu($top, 'FAQ', 'help-browser.png'), -command => [\&showFile, "$usrshare/FAQ"]) if (-f "$usrshare/FAQ");
+
+ $top->configure(-menu => $menubar) if $config{ShowMenu};
+ }
+@@ -16381,7 +16382,7 @@
+ my $picName = shift;
+ my $func = shift;
+
+- my $pic = "$configdir/$picName";
++ my $pic = "$usrshare/pics/$picName";
+ my $image = $parentWidget->Photo(-file => $pic) if -f $pic;
+
+ if ($image) {
+@@ -20396,7 +20397,7 @@
+ if (!-d $configdir) {
+ # ask the user for permission to create a configdir
+ my $rc = $top->messageBox(-icon => 'question',
+- -message => "MaPiVi would like to create a folder \"$configdir\" in your home folder to store the configuration of Mapivi and some button and background pictures.",
++ -message => "MaPiVi would like to create a folder \"$configdir\" in your home folder to store the configuration of Mapivi.",
+ -title => "Mapivi installation", -type => 'OKCancel');
+ return if ($rc !~ m/Ok/i);
+ }
+@@ -20436,7 +20437,9 @@
+
+ if (!-d $plugindir) {
+ if ( !mkdir "$plugindir", 0755 ) {
+- $top->messageBox(-icon => 'warning', -message => "Error making PlugIn dir $plugindir: $!",
++ # RJW: This will likely not work if $usrshare is /usr/share/mapivi
++ # and the user is not root.
++ $top->messageBox(-icon => 'warning', -message => "Error making PlugIn dir $plugindir (should be created by installer?): $!",
+ -title => "Mapivi installation", -type => 'OK');
+ return;
+ }
+@@ -23741,7 +23744,7 @@
+ my $stopB = $subF->Button(-text => "Stop",
+ -command => sub { $stop = 1; }
+ )->pack(-side => 'left', -anchor => 'w', -expand => 0,-padx => 1,-pady => 1);
+- my $stopImg = $top->Photo(-file => "$configdir/StopPic.gif") if (-f "$configdir/StopPic.gif");
++ my $stopImg = $top->Photo(-file => "$usrshare/pics/StopPic.gif") if (-f "$usrshare/pics/StopPic.gif");
+ $stopB->configure(-image => $stopImg, -borderwidth => 0) if $stopImg;
+ $stopB->configure(-state => "disabled");
+
+@@ -24896,7 +24899,7 @@
+ $stopB = $SButF->Button(-text => "Stop",
+ -command => sub { $stop = 1; }
+ )->pack(-side => 'left', -anchor => 'w', -expand => 0,-padx => 1,-pady => 1);
+- my $stopImg = $top->Photo(-file => "$configdir/StopPic.gif") if (-f "$configdir/StopPic.gif");
++ my $stopImg = $top->Photo(-file => "$usrshare/pics/StopPic.gif") if (-f "$usrshare/pics/StopPic.gif");
+ $stopB->configure(-image => $stopImg, -borderwidth => 0) if $stopImg;
+ $stopB->configure(-state => "disabled");
+
+@@ -28742,7 +28745,7 @@
+ my $stopB = $butF->Button(-text => "Stop",
+ -command => sub { $stop = 1; }
+ )->pack(-side => 'left', -anchor => 'w', -expand => 0,-padx => 1,-pady => 1);
+- my $stopImg = $top->Photo(-file => "$configdir/StopPic.gif") if (-f "$configdir/StopPic.gif");
++ my $stopImg = $top->Photo(-file => "$usrshare/pics/StopPic.gif") if (-f "$usrshare/pics/StopPic.gif");
+ $stopB->configure(-image => $stopImg, -borderwidth => 0) if $stopImg;
+ $stopB->configure(-state => "disabled");
+
+@@ -29425,6 +29428,7 @@
+
+ my $string = << "EOA";
+ Mapivi config dir: $configdir
++ Mapivi static dir: $usrshare
+
+ Perl version: $perlversion
+ Perl/Tk version: $Tk::VERSION
diff --git a/08_removeMousePod.diff b/08_removeMousePod.diff
new file mode 100644
index 000000000000..0433bacbea29
--- /dev/null
+++ b/08_removeMousePod.diff
@@ -0,0 +1,40 @@
+--- mapivi.orig 2008-02-21 21:53:44.000000000 +0100
++++ mapivi 2009-04-03 17:41:00.000000000 +0200
+@@ -8110,37 +8110,6 @@
+ } )->pack(-side => 'left', -expand => 0, -fill => 'x', -padx => 1, -pady => 1);
+ $balloon->attach($addB, -msg => "Add the selected keywords to the selected pictures");
+
+-=pod
+-
+- my $rmB =
+- $af->Button(-text => "remove",
+- -command => sub {
+- my @keys = $keytree->info('selection');
+- return unless checkSelection($keycw, 1, 0, \@keys);
+- my @sellist = $lb->info('selection');
+- return unless checkSelection($top, 1, 0, \@sellist);
+- my $pw = progressWinInit($keycw, "Remove keyword");
+- my $i = 0;
+- my $sum = @sellist;
+- foreach my $dpic (@sellist) {
+- last if progressWinCheck($pw);
+- $i++;
+- progressWinUpdate($pw, "removing keyword ($i/$sum) ...", $i, $sum);
+- foreach my $key (@keys) {
+- last if progressWinCheck($pw);
+- progressWinUpdate($pw, "removing keyword $key ($i/$sum) ...", $i, $sum);
+- my $name = getLastItem($key);
+- print "remove key $name ($key) from $dpic\n" if $verbose;
+- removeIPTCItem($dpic, 'Keywords', $name);
+- updateOneRow($dpic, $lb);
+- }
+- }
+- progressWinEnd($pw);
+- })->pack(-side => 'left', -expand => 0, -fill => 'x', -padx => 1, -pady => 1);
+- $balloon->attach($rmB, -msg => "Remove the selected keywords from the selected pictures");
+-
+-=cut
+-
+ $keytree = $keycw->Scrolled('Tree',
+ -separator => '/',
+ -scrollbars => 'osoe',
diff --git a/09_qw_parentheses.diff b/09_qw_parentheses.diff
new file mode 100644
index 000000000000..22509e087491
--- /dev/null
+++ b/09_qw_parentheses.diff
@@ -0,0 +1,38 @@
+--- mapivi.orig 2009-04-03 17:44:30.000000000 +0200
++++ mapivi 2013-10-22 18:30:56.925667829 +0200
+@@ -10123,11 +10123,11 @@
+ my $pf = $pfa->Frame(-bd => $config{Borderwidth}, -relief => 'groove')->pack(-side => "left");
+ my $pfn = $pf->Frame()->pack();
+ my $pfs = $pf->Frame()->pack();
+- foreach my $gravity qw(NorthWest North NorthEast) {
++ foreach my $gravity (qw(NorthWest North NorthEast)) {
+ my $but = $pfn->Radiobutton(-text => "", -variable => \$config{CopyPosition}, -value => $gravity)->pack(-side => 'left');
+ $balloon->attach($but, -msg => "Align the copyright text or logo in $gravity position");
+ }
+- foreach my $gravity qw(SouthWest South SouthEast) {
++ foreach my $gravity (qw(SouthWest South SouthEast)) {
+ my $but = $pfs->Radiobutton(-text => "", -variable => \$config{CopyPosition}, -value => $gravity)->pack(-side => 'left');
+ $balloon->attach($but, -msg => "Align the copyright text or logo in $gravity position");
+ }
+@@ -19972,7 +19972,7 @@
+ ##############################################################
+ sub normalizeCoords {
+ my $canvas = shift;
+- foreach my $coord qw(m_x1 m_x2 m_y1 m_y2) {
++ foreach my $coord (qw(m_x1 m_x2 m_y1 m_y2)) {
+ # assign it to the step width
+ $canvas->{$coord} = sprintf "%.0f", ($canvas->{$coord}/$canvas->{m_step});
+ $canvas->{$coord} *= $canvas->{m_step};
+@@ -19981,10 +19981,10 @@
+ }
+
+ # check upper bound
+- foreach my $coord qw(m_x1 m_x2) {
++ foreach my $coord (qw(m_x1 m_x2)) {
+ $canvas->{$coord} = $canvas->{m_wo} if ($canvas->{$coord} > $canvas->{m_wo});
+ }
+- foreach my $coord qw(m_y1 m_y2) {
++ foreach my $coord (qw(m_y1 m_y2)) {
+ $canvas->{$coord} = $canvas->{m_ho} if ($canvas->{$coord} > $canvas->{m_ho});
+ }
+ }
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc23830b5a0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Archie <xMickael@ifrance.com>
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=mapivi
+pkgver=097
+pkgrel=1
+pkgdesc="A photo management tool with focus on JPEG pictures. Mapivi supports adding, editing and searching of IPTC/IIM, EXIF data and JPEG comments. The pictures are managed in place (in your folder structure)."
+depends=('jpegpixi' 'jhead' 'imagemagick' 'libjpeg' 'perl-image-info' 'perl-image-metadata-jpeg' 'tk-matchentry' 'tk-resizebutton' 'tk-splash' 'perl-tk' 'perl-exiftool')
+arch=('i686' 'x86_64')
+license=('GPL')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname$pkgver.tar.gz mapivi mapivi.desktop mapivi.png 07_usrShareMapivi.diff 08_removeMousePod.diff 09_qw_parentheses.diff)
+url="http://mapivi.sourceforge.net/mapivi.shtml"
+md5sums=('f1432cbb0033c1a1a324651dbc0700b2'
+ '85f09ddc913d654ea92fa987838bcc63'
+ '5e34164357ee0351d68fd4ca048d99ac'
+ '15d8e83af7ccfa852774a48d2fb1ba75'
+ '59e1b327f32eea54e28463295f67496b'
+ '001918d8da9a54446df603e2c2804592'
+ '18937b9307fab48277499b76952439d0')
+
+package() {
+ cd $srcdir/$pkgname$pkgver
+ mkdir -p $pkgdir/usr/{share,bin}
+ mkdir -p $pkgdir/usr/share/{$pkgname,applications,pixmaps}
+ mkdir -p $pkgdir/usr/share/$pkgname/{html,icons,pics,PlugIns}
+
+ # applying a few patches from debian
+ for file in $srcdir/*diff
+ do
+ patch -p0 < "$file"
+ done
+
+ cp pics/* $pkgdir/usr/share/$pkgname/pics/
+ cp html/* $pkgdir/usr/share/$pkgname/html/
+ cp icons/* $pkgdir/usr/share/$pkgname/icons/
+ cp PlugIns/* $pkgdir/usr/share/$pkgname/PlugIns/
+ cp {COPYING,FAQ,INSTALL,mapivi,README,Changes.txt,License.txt,Tips.txt} $pkgdir/usr/share/$pkgname/
+
+ install -m755 $srcdir/mapivi $pkgdir/usr/bin/mapivi
+ install -m644 $srcdir/mapivi.desktop $pkgdir/usr/share/applications/
+ install -m655 $srcdir/mapivi.png $pkgdir/usr/share/pixmaps/
+
+ chmod 644 $pkgdir/usr/share/mapivi/icons/*
+}
diff --git a/mapivi b/mapivi
new file mode 100755
index 000000000000..2f07827c1f6a
--- /dev/null
+++ b/mapivi
@@ -0,0 +1,14 @@
+#! /bin/sh
+
+if [ -f $HOME/.maprogs/mapivi/icons/folder.png ]
+then
+ cd /usr/share/mapivi/
+ perl mapivi || return 1
+else
+ mkdir -p $HOME/.maprogs/mapivi/{icons,PlugIns}
+ cp /usr/share/mapivi/icons/* $HOME/.maprogs/mapivi/icons/
+ cp /usr/share/mapivi/PlugIns/* $HOME/.maprogs/mapivi/PlugIns/
+ cd /usr/share/mapivi
+ perl mapivi || return 1
+
+fi
diff --git a/mapivi.desktop b/mapivi.desktop
new file mode 100644
index 000000000000..9391f5384577
--- /dev/null
+++ b/mapivi.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories= Graphics;Viewer;
+Name=Mapivi
+GenericName=Picture manager and organizer
+GenericName[fr]=Gestionnaire de photographies
+Comment=Picture manager and organizer with complete meta information support.
+Comment[fr]=Gestionnaire de photographies avec un support des champs exif/iptc.
+Exec=/usr/bin/mapivi %F
+Icon=/usr/share/pixmaps/mapivi
+
diff --git a/mapivi.png b/mapivi.png
new file mode 100644
index 000000000000..e148249a7027
--- /dev/null
+++ b/mapivi.png
Binary files differ