summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Hummel2023-11-20 11:05:14 -0700
committerDavid Hummel2023-11-20 11:05:14 -0700
commit4aaf684b86e2b7928d0d512685fc4ca96692ecd0 (patch)
tree5df5a9151c21c34b2c47b75cf9645917b2b689bc
parentfa462e39b229ebb45905bac24ae0878545c6938e (diff)
downloadaur-4aaf684b86e2b7928d0d512685fc4ca96692ecd0.tar.gz
Fixing build after libxml2 upgrade and recent merge
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--mapnik-libxml2_loader.patch22
-rw-r--r--mapnik-plugins-input-ogr-cmakelists.patch12
-rw-r--r--mapnik-test-cmakelists.patch12
5 files changed, 63 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 672d5430855e..5f65a5cb94a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mapnik-git
pkgdesc = Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)
- pkgver = 4.0.0.r13795.gf391178
+ pkgver = 4.0.0.r13800.gd745e43
pkgrel = 1
url = https://github.com/mapnik/mapnik
arch = i686
@@ -34,10 +34,16 @@ pkgbase = mapnik-git
source = git+https://github.com/mapnik/mapnik.git
source = mapnik-cmake-harfbuzz.patch
source = mapnik-datasource-ogr-test.patch
+ source = mapnik-libxml2_loader.patch
+ source = mapnik-plugins-input-ogr-cmakelists.patch
+ source = mapnik-test-cmakelists.patch
source = git+https://github.com/mapnik/test-data.git
sha256sums = SKIP
sha256sums = 90f541c0845e3c7005564fa113771ce01cf2bcfd57662b7fa8849aabf4151638
sha256sums = 3fcf178e646df526e9a5c278f56ad16e4f75d2f27108e7b33419649a46b92f52
+ sha256sums = 505b3e9337f27c4be4822a37e37b335bff6f6322d5ec3d8da55b4792b05662b5
+ sha256sums = 36bb2426f4de823f10b4e5025bd9e0eccfac069084bfe99093a8348c3ae9124e
+ sha256sums = fd15a5bb2829bfb3cbebbf380c5c3fb14d57727198c6e851afae717681d15796
sha256sums = SKIP
pkgname = mapnik-git
diff --git a/PKGBUILD b/PKGBUILD
index 05f1c12bd67d..97f2796c50b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Maintainer: David Hummel <david dot hummel at gmail point com>
pkgname=mapnik-git
-pkgver=4.0.0.r13795.gf391178
+pkgver=4.0.0.r13800.gd745e43
pkgrel=1
pkgdesc='Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)'
arch=('i686' 'x86_64')
@@ -40,10 +40,16 @@ provides=('mapnik')
source=('git+https://github.com/mapnik/mapnik.git'
'mapnik-cmake-harfbuzz.patch'
'mapnik-datasource-ogr-test.patch'
+ 'mapnik-libxml2_loader.patch' # Support libxml2 >= v2.12.0
+ 'mapnik-plugins-input-ogr-cmakelists.patch' # Fix build after #4420
+ 'mapnik-test-cmakelists.patch' # Fix build after #4420
'git+https://github.com/mapnik/test-data.git')
sha256sums=('SKIP'
'90f541c0845e3c7005564fa113771ce01cf2bcfd57662b7fa8849aabf4151638'
'3fcf178e646df526e9a5c278f56ad16e4f75d2f27108e7b33419649a46b92f52'
+ '505b3e9337f27c4be4822a37e37b335bff6f6322d5ec3d8da55b4792b05662b5'
+ '36bb2426f4de823f10b4e5025bd9e0eccfac069084bfe99093a8348c3ae9124e'
+ 'fd15a5bb2829bfb3cbebbf380c5c3fb14d57727198c6e851afae717681d15796'
'SKIP')
pkgver() {
@@ -55,6 +61,9 @@ prepare() {
cd mapnik || exit
patch -Np1 < ../mapnik-cmake-harfbuzz.patch
patch -Np1 < ../mapnik-datasource-ogr-test.patch
+ patch -Np1 < ../mapnik-libxml2_loader.patch
+ patch -Np1 < ../mapnik-plugins-input-ogr-cmakelists.patch
+ patch -Np1 < ../mapnik-test-cmakelists.patch
git submodule init \
test/data
git config submodule.test/data.url "$srcdir"/test-data
diff --git a/mapnik-libxml2_loader.patch b/mapnik-libxml2_loader.patch
new file mode 100644
index 000000000000..5e44923f6975
--- /dev/null
+++ b/mapnik-libxml2_loader.patch
@@ -0,0 +1,22 @@
+diff --git a/src/libxml2_loader.cpp b/src/libxml2_loader.cpp
+index 223d8df44..78dc8aa97 100644
+--- a/src/libxml2_loader.cpp
++++ b/src/libxml2_loader.cpp
+@@ -88,7 +88,7 @@ class libxml2_loader : util::noncopyable
+
+ if (!doc)
+ {
+- xmlError* error = xmlCtxtGetLastError(ctx_);
++ const xmlError* error = xmlCtxtGetLastError(ctx_);
+ if (error)
+ {
+ std::string msg("XML document not well formed:\n");
+@@ -128,7 +128,7 @@ class libxml2_loader : util::noncopyable
+ if (!doc)
+ {
+ std::string msg("XML document not well formed");
+- xmlError* error = xmlCtxtGetLastError(ctx_);
++ const xmlError* error = xmlCtxtGetLastError(ctx_);
+ if (error)
+ {
+ msg += ":\n";
diff --git a/mapnik-plugins-input-ogr-cmakelists.patch b/mapnik-plugins-input-ogr-cmakelists.patch
new file mode 100644
index 000000000000..9b6fc695fa00
--- /dev/null
+++ b/mapnik-plugins-input-ogr-cmakelists.patch
@@ -0,0 +1,12 @@
+diff --git a/plugins/input/ogr/CMakeLists.txt b/plugins/input/ogr/CMakeLists.txt
+index 8f1fe9aff..3f3d11f9e 100644
+--- a/plugins/input/ogr/CMakeLists.txt
++++ b/plugins/input/ogr/CMakeLists.txt
+@@ -4,6 +4,7 @@ add_plugin_target(input-ogr "ogr")
+ target_sources(input-ogr ${_plugin_visibility}
+ ogr_converter.cpp
+ ogr_datasource.cpp
++ ogr_utils.cpp
+ ogr_featureset.cpp
+ ogr_index_featureset.cpp
+ )
diff --git a/mapnik-test-cmakelists.patch b/mapnik-test-cmakelists.patch
new file mode 100644
index 000000000000..15c42adb9162
--- /dev/null
+++ b/mapnik-test-cmakelists.patch
@@ -0,0 +1,12 @@
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index f275df53f..d15edecda 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -34,6 +34,7 @@ add_executable(mapnik-test-unit
+ unit/datasource/geobuf.cpp
+ unit/datasource/geojson.cpp
+ unit/datasource/memory.cpp
++ ../plugins/input/ogr/ogr_utils.cpp
+ unit/datasource/ogr.cpp
+ unit/datasource/postgis.cpp
+ unit/datasource/shapeindex.cpp