summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Hummel2024-01-30 18:41:02 -0700
committerDavid Hummel2024-01-30 18:41:02 -0700
commit54f7f1493cbf6ce563e9f580e84afd3eb150576b (patch)
tree9eefc0258b5e82cd7a2af5b3ecacb455a2e601da
parent4b4b643eac9454b024e5bf2ed96f328117046cbf (diff)
downloadaur-54f7f1493cbf6ce563e9f580e84afd3eb150576b.tar.gz
Move commands around slightly
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79ecf18414fb..e5634bfbd4e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -61,6 +61,9 @@ prepare() {
git config submodule.test/data.url "$srcdir"/test-data
git -c protocol.file.allow=always submodule update \
test/data
+
+ # Remove bundled sparsehash directory in favor of 'sparsehash' package
+ rm -rf deps/mapnik/sparsehash
}
build() {
@@ -87,15 +90,13 @@ package(){
# Remove bundled dejavu fonts from cmake_install.cmake in favor of 'ttf-dejavu' package
sed -i '/dejavu-fonts-ttf/d' "$srcdir"/mapnik_build/cmake_install.cmake
- # Remove bundled sparsehash directory in favor of 'sparsehash' package
- rm -rf "$srcdir"/mapnik/deps/mapnik/sparsehash
-
- # Install to #DESTDIR
+ # Install to $DESTDIR
DESTDIR="$pkgdir" cmake --install mapnik_build --strip
- # Remove usr/share/fonts directory
- rm -rf "$pkgdir"/usr/share/fonts
-
# License
install -Dm644 "$srcdir"/mapnik/COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+
+ # Remove usr/share/fonts directory
+ pushd "$pkgdir"
+ rm -rf usr/share/fonts
}