summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Hummel2023-12-26 14:27:13 -0700
committerDavid Hummel2023-12-26 14:27:13 -0700
commit77628c452677574b8a4f21c40f2f268799ba6442 (patch)
treef13cee8d7b7c4161f70813a4ad16a4ff6aa3f406
parent9ecef05d5f10846c52035a8aabd294d458493168 (diff)
downloadaur-77628c452677574b8a4f21c40f2f268799ba6442.tar.gz
Remove no-longer-needed patch files & update pkgver
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--mapnik-cmake-harfbuzz.patch26
3 files changed, 2 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 401b929b9dfb..6ad59aa6c212 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mapnik-git
pkgdesc = Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)
pkgver = 4.0.0.r13808.g2e1b325
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mapnik/mapnik
arch = i686
arch = x86_64
@@ -32,11 +32,9 @@ pkgbase = mapnik-git
provides = mapnik
conflicts = mapnik
source = git+https://github.com/mapnik/mapnik.git
- source = mapnik-cmake-harfbuzz.patch
source = mapnik-datasource-ogr-test.patch
source = git+https://github.com/mapnik/test-data.git
sha256sums = SKIP
- sha256sums = 90f541c0845e3c7005564fa113771ce01cf2bcfd57662b7fa8849aabf4151638
sha256sums = 3fcf178e646df526e9a5c278f56ad16e4f75d2f27108e7b33419649a46b92f52
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2e0befdce9c9..30aa427e9c75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=mapnik-git
pkgver=4.0.0.r13808.g2e1b325
-pkgrel=1
+pkgrel=2
pkgdesc='Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)'
arch=('i686' 'x86_64')
url='https://github.com/mapnik/mapnik'
@@ -38,11 +38,9 @@ makedepends=('boost'
conflicts=('mapnik')
provides=('mapnik')
source=('git+https://github.com/mapnik/mapnik.git'
- 'mapnik-cmake-harfbuzz.patch'
'mapnik-datasource-ogr-test.patch'
'git+https://github.com/mapnik/test-data.git')
sha256sums=('SKIP'
- '90f541c0845e3c7005564fa113771ce01cf2bcfd57662b7fa8849aabf4151638'
'3fcf178e646df526e9a5c278f56ad16e4f75d2f27108e7b33419649a46b92f52'
'SKIP')
@@ -53,7 +51,6 @@ pkgver() {
prepare() {
cd mapnik || exit
- patch -Np1 < ../mapnik-cmake-harfbuzz.patch
patch -Np1 < ../mapnik-datasource-ogr-test.patch
git submodule init \
test/data
diff --git a/mapnik-cmake-harfbuzz.patch b/mapnik-cmake-harfbuzz.patch
deleted file mode 100644
index 1c920249af40..000000000000
--- a/mapnik-cmake-harfbuzz.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ffb86d4ac..1775b986f 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -177,19 +177,8 @@ endif()
-
- mapnik_find_package(Freetype REQUIRED)
-
--# try to find harfbuzz with the native configuration and fallback to our "own" FindHarfBuzz
--mapnik_find_package(harfbuzz CONFIG QUIET)
--if(harfbuzz_FOUND)
-- message(STATUS "Found harfbuzz native cmake")
-- list(APPEND MAPNIK_OPTIONAL_LIBS harfbuzz::harfbuzz)
--else()
-- # Use pkg-config when harfbuzz is not found.
-- # It might be possible that in future version harfbuzz could only be found via pkg-config.
-- # harfbuzz related discussion: https://github.com/harfbuzz/harfbuzz/issues/2653
-- message(STATUS "harfbuzz not found via cmake. Searching via pkg-config...")
-- mapnik_pkg_check_modules(harfbuzz REQUIRED IMPORTED_TARGET harfbuzz>=${HARFBUZZ_MIN_VERSION})
-- list(APPEND MAPNIK_OPTIONAL_LIBS PkgConfig::harfbuzz)
--endif()
-+mapnik_pkg_check_modules(harfbuzz REQUIRED IMPORTED_TARGET harfbuzz>=${HARFBUZZ_MIN_VERSION})
-+list(APPEND MAPNIK_OPTIONAL_LIBS PkgConfig::harfbuzz)
-
- if(USE_EXTERNAL_MAPBOX_GEOMETRY)
- # this is used to provide a way to specify include dirs with CACHE VARIABLES