summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2018-09-10 20:30:37 -0500
committerSamuel Mesa2018-09-10 20:30:37 -0500
commitd2677003a05446414a0563bc9bb087e240bb00a5 (patch)
tree5c32fa1a0a269da9aadd64329057766953f6a2bc
parent4d938df925b832bc713451246b4c72706a903c59 (diff)
downloadaur-d2677003a05446414a0563bc9bb087e240bb00a5.tar.gz
Patch CMAKE 3.12
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--cmake-3.12.patch73
3 files changed, 87 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd12760efa99..5208f365f82c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mapserver
pkgdesc = Platform for publishing spatial data and interactive mapping applications to the web
pkgver = 7.2.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.mapserver.org
arch = i686
arch = x86_64
@@ -26,7 +26,9 @@ pkgbase = mapserver
depends = libsvg-cairo
depends = fribidi
source = http://download.osgeo.org/mapserver/mapserver-7.2.0.tar.gz
+ source = cmake-3.12.patch
md5sums = 78566f7eeb3fd7fed4f3816612bc89ed
+ md5sums = 4f336526a3a0b20ef784d8c8c88e38df
pkgname = mapserver
diff --git a/PKGBUILD b/PKGBUILD
index 4c893a3ce63d..ddf13d2b480a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mapserver
pkgver=7.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Platform for publishing spatial data and interactive mapping applications to the web"
arch=(i686 x86_64)
license=('MIT')
@@ -14,8 +14,16 @@ depends=('libpng' 'freetype2' 'zlib' 'gdal' 'proj' 'libjpeg-turbo' 'libxml2' 'li
## For v8 support require v8-3.20; for PHP mapscript require php, php-pear, php-apache
makedepends=('cfitsio')
options=()
-source=("http://download.osgeo.org/mapserver/mapserver-${pkgver}.tar.gz")
-md5sums=('78566f7eeb3fd7fed4f3816612bc89ed')
+source=("http://download.osgeo.org/mapserver/mapserver-${pkgver}.tar.gz" "cmake-3.12.patch")
+md5sums=('78566f7eeb3fd7fed4f3816612bc89ed'
+ '4f336526a3a0b20ef784d8c8c88e38df')
+
+
+prepare() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+
+ patch -Np1 -i ../cmake-3.12.patch
+}
build() {
cd ${startdir}/src/${pkgname}-${pkgver}
diff --git a/cmake-3.12.patch b/cmake-3.12.patch
new file mode 100644
index 000000000000..7f139ded4a6b
--- /dev/null
+++ b/cmake-3.12.patch
@@ -0,0 +1,73 @@
+Description: Fix errors with CMake 3.12 for get_target_property commands.
+Author: Bas Couwenberg <sebastic@debian.org>
+Bug: https://github.com/mapserver/mapserver/issues/5646
+Bug-Debian: https://bugs.debian.org/906605
+
+--- a/mapscript/java/CMakeLists.txt
++++ b/mapscript/java/CMakeLists.txt
+@@ -42,6 +42,14 @@ ADD_CUSTOM_COMMAND(TARGET javamapscript
+ COMMENT "Compiling java source files, creating mapscript.jar"
+ )
+
++# Workaround for CMake 3.12 error:
++#
++# The LOCATION property may not be read from target "foo". Use
++# the target name directly with add_custom_command, or use the generator
++# expression $<TARGET_FILE>, as appropriate.
++
++cmake_policy(SET CMP0026 OLD)
++
+ get_target_property(LOC_MAPSCRIPT_LIB ${SWIG_MODULE_javamapscript_REAL_NAME} LOCATION)
+ install(FILES ${LOC_MAPSCRIPT_LIB} DESTINATION lib/jni)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/mapscript.jar DESTINATION share/java)
+--- a/mapscript/perl/CMakeLists.txt
++++ b/mapscript/perl/CMakeLists.txt
+@@ -18,6 +18,14 @@ if(APPLE)
+ set_target_properties(perlmapscript PROPERTIES SUFFIX ".bundle")
+ endif(APPLE)
+
++# Workaround for CMake 3.12 error:
++#
++# The LOCATION property may not be read from target "foo". Use
++# the target name directly with add_custom_command, or use the generator
++# expression $<TARGET_FILE>, as appropriate.
++
++cmake_policy(SET CMP0026 OLD)
++
+ get_target_property(LOC_MAPSCRIPT_LIB ${SWIG_MODULE_perlmapscript_REAL_NAME} LOCATION)
+ set(mapscript_files ${LOC_MAPSCRIPT_LIB} ${CMAKE_CURRENT_BINARY_DIR}/mapscript.pm)
+ install(FILES ${LOC_MAPSCRIPT_LIB} DESTINATION ${CUSTOM_PERL_VENDOR_ARCH_DIR}/auto/mapscript)
+--- a/mapscript/python/CMakeLists.txt
++++ b/mapscript/python/CMakeLists.txt
+@@ -39,6 +39,14 @@ set_target_properties(${SWIG_MODULE_pyth
+
+ execute_process ( COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(True))" OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
+
++# Workaround for CMake 3.12 error:
++#
++# The LOCATION property may not be read from target "foo". Use
++# the target name directly with add_custom_command, or use the generator
++# expression $<TARGET_FILE>, as appropriate.
++
++cmake_policy(SET CMP0026 OLD)
++
+ get_target_property(LOC_MAPSCRIPT_LIB ${SWIG_MODULE_pythonmapscript_REAL_NAME} LOCATION)
+ set(mapscript_files ${LOC_MAPSCRIPT_LIB} ${CMAKE_CURRENT_BINARY_DIR}/mapscript.py)
+ install(FILES ${mapscript_files} DESTINATION ${PYTHON_SITE_PACKAGES})
+--- a/mapscript/ruby/CMakeLists.txt
++++ b/mapscript/ruby/CMakeLists.txt
+@@ -32,6 +32,14 @@ if(APPLE)
+ set_target_properties(${SWIG_MODULE_rubymapscript_REAL_NAME} PROPERTIES SUFFIX ".bundle")
+ endif(APPLE)
+
++# Workaround for CMake 3.12 error:
++#
++# The LOCATION property may not be read from target "foo". Use
++# the target name directly with add_custom_command, or use the generator
++# expression $<TARGET_FILE>, as appropriate.
++
++cmake_policy(SET CMP0026 OLD)
++
+ get_target_property(LOC_MAPSCRIPT_LIB ${SWIG_MODULE_rubymapscript_REAL_NAME} LOCATION)
+ execute_process(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts RbConfig::CONFIG['vendorarchdir']" OUTPUT_VARIABLE RUBY_VENDORARCHDIR OUTPUT_STRIP_TRAILING_WHITESPACE)
+ install(FILES ${LOC_MAPSCRIPT_LIB} DESTINATION ${RUBY_VENDORARCHDIR})