summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÁdám Barancsuk2015-06-11 13:20:18 +0200
committerÁdám Barancsuk2015-06-11 13:20:18 +0200
commit73cf3a1e8d61fc4ad15d2a4a1edfeb11226fb429 (patch)
treefa18a510936638929788b5a83799a7e0f7b225ca
downloadaur-73cf3a1e8d61fc4ad15d2a4a1edfeb11226fb429.tar.gz
Initial commit.
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD99
2 files changed, 135 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30e7e0622b9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by makepkg 4.2.1
+# Thu Jun 11 11:19:38 UTC 2015
+pkgbase = mapserver-git
+ pkgdesc = Platform for publishing spatial data and interactive mapping applications to the web
+ pkgver = 7.0.0.beta1.r28.g61592a7
+ pkgrel = 1
+ url = http://www.mapserver.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cfitsio
+ depends = libpng
+ depends = freetype2
+ depends = gd
+ depends = zlib
+ depends = gdal
+ depends = proj
+ depends = libjpeg-turbo
+ depends = libxml2
+ depends = libpqxx
+ depends = pdflib-lite
+ depends = geos
+ depends = agg
+ depends = apache
+ depends = fcgi
+ depends = mod_fastcgi
+ depends = python2
+ depends = swig
+ depends = libsvg-cairo
+ provides = mapserver-git=7.0.0.beta1.r28.g61592a7
+ conflicts = mapserver
+ source = mapserver-git::git://github.com/mapserver/mapserver.git
+ md5sums = SKIP
+
+pkgname = mapserver-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5548043c5e57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,99 @@
+# Maintainer: Samuel Mesa <samuelmesa@linuxmail.org>
+# Contributor: Marcos Piccinini <x@nofxx.com>
+# Contributor: Jonathan Hudson <jh+arch@daria.co.uk>
+pkgname=mapserver-git
+pkgver=7.0.0.beta1.r28.g61592a7
+pkgrel=1
+pkgdesc="Platform for publishing spatial data and interactive mapping applications to the web"
+arch=(i686 x86_64)
+license=('MIT')
+url="http://www.mapserver.org"
+depends=('libpng' 'freetype2' 'gd' 'zlib' 'gdal' 'proj' 'libjpeg-turbo' 'libxml2' 'libpqxx' 'pdflib-lite' 'geos' 'agg' 'apache' 'fcgi' 'mod_fastcgi' 'python2' 'swig' 'libsvg-cairo')
+makedepends=('cfitsio')
+options=()
+provides=("${pkgname}=${pkgver}")
+conflicts=('mapserver')
+source=("${pkgname}"::'git://github.com/mapserver/mapserver.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/^rel-//g;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${srcdir}/${pkgname}
+
+ if [ -f CMakeCache.txt ]
+ then
+ rm -rf CMakeCache.txt CMakeFiles
+ fi
+ rm -rf build && mkdir build
+ cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_LIBRARIES=/usr/lib/python2.7 \
+ -DPYTHON_INCLUDE_PATH=/usr/include/python2.7 \
+ -DFRIBIDI_INCLUDE_DIR="/usr/include/glib-2.0;/usr/lib/glib-2.0/include;/usr/include/fribidi" \
+ -DWITH_CAIRO=ON \
+ -DWITH_CLIENT_WFS=ON \
+ -DWITH_CLIENT_WMS=ON \
+ -DWITH_CSHARP=OFF \
+ -DWITH_CURL=ON \
+ -DWITH_EXEMPI=OFF \
+ -DWITH_FCGI=ON \
+ -DWITH_FRIBIDI=ON \
+ -DWITH_GD=OFF \
+ -DWITH_GDAL=ON \
+ -DWITH_GENERIC_NINT=OFF \
+ -DWITH_GEOS=ON \
+ -DWITH_GIF=OFF \
+ -DWITH_ICONV=ON \
+ -DWITH_JAVA=OFF \
+ -DWITH_KML=ON \
+ -DWITH_LIBXML2=ON \
+ -DWITH_MSSQL2008=OFF \
+ -DWITH_MYSQL=OFF \
+ -DWITH_OGR=ON \
+ -DWITH_ORACLESPATIAL=OFF \
+ -DWITH_ORACLE_PLUGIN=OFF \
+ -DWITH_PERL=OFF \
+ -DWITH_PHP=OFF \
+ -DWITH_POINT_Z_M=OFF \
+ -DWITH_POSTGIS=ON \
+ -DWITH_PROJ=ON \
+ -DWITH_PYTHON=ON \
+ -DWITH_RSVG=OFF \
+ -DWITH_RUBY=OFF \
+ -DWITH_SDE=OFF \
+ -DWITH_SDE_PLUGIN=OFF \
+ -DWITH_SOS=ON \
+ -DWITH_SVGCAIRO=ON \
+ -DWITH_THREAD_SAFETY=ON \
+ -DWITH_WCS=ON \
+ -DWITH_WFS=ON \
+ -DWITH_WMS=ON \
+ -DWITH_XMLMAPFILE=OFF \
+ -DFREETYPE_INCLUDE_DIR=/usr/include/freetype2 \
+
+ make clean
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ cd build
+
+ make || return 1
+ make DESTDIR=${pkgdir} install
+
+ # Copy the headers a include for ZooWPS project
+ mkdir -p "$pkgdir"/usr/include/mapserver
+ cp "${srcdir}/${pkgname}"/*.h "${pkgdir}"/usr/include/mapserver/
+
+ # Move stuff from lib64 to lib
+ mv "${pkgdir}"/usr/lib64/* "${pkgdir}"/usr/lib
+ rm -r "${pkgdir}"/usr/lib64
+}