summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Walters2019-03-18 02:15:28 -0400
committerMathias Walters2019-03-18 02:15:28 -0400
commit8463d2e12a35c74e2a9f673a1bb1bdb06b471990 (patch)
treecef0a66e15a9e92988f07b648e62de96b17bac24
downloadaur-8463d2e12a35c74e2a9f673a1bb1bdb06b471990.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--MapTool.desktop7
-rw-r--r--PKGBUILD22
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c97e00180bf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = maptool-stable-bin
+ pkgdesc = The stable release of an open source virtual tabletop program
+ pkgver = 1.4.1.8
+ pkgrel = 1
+ url = https://rptools.net/tools/maptool
+ arch = x86_64
+ license = AGPL3
+ provides = maptool
+ conflicts = maptool
+ source = https://download.rptools.net/zip/maptool-linux64-1.4.1.8.tar
+ source = MapTool.desktop
+ sha256sums = e0a96e7349db16d2553ec976d2db8f810a3fa4b5b4ba4c22aee5e609e10ff15b
+ sha256sums = 524c13b4ebdbc392255c1fc7dbb112ab4bb9898186871fa23b3dab1c1edd16bd
+
+pkgname = maptool-stable-bin
+
diff --git a/MapTool.desktop b/MapTool.desktop
new file mode 100644
index 000000000000..b3979fec17cf
--- /dev/null
+++ b/MapTool.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=MapTool
+Comment=MapTool
+Exec=MapTool-linux64-offline
+Terminal=false
+Type=Application
+Categories=Unknown
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c30b1a7c28a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mathias Walters <waltersm at protonmail dot com>
+
+pkgname=maptool-stable-bin
+pkgver=1.4.1.8
+pkgrel=1
+pkgdesc="The stable release of an open source virtual tabletop program"
+arch=('x86_64')
+url="https://rptools.net/tools/maptool"
+license=('AGPL3')
+provides=('maptool')
+conflicts=('maptool')
+source=("https://download.rptools.net/zip/maptool-linux64-${pkgver}.tar" "MapTool.desktop")
+sha256sums=('e0a96e7349db16d2553ec976d2db8f810a3fa4b5b4ba4c22aee5e609e10ff15b' '524c13b4ebdbc392255c1fc7dbb112ab4bb9898186871fa23b3dab1c1edd16bd')
+
+package() {
+
+ tar -C "${pkgdir}" -xf maptool-linux64-${pkgver}.tar
+
+ install -Dm755 "${pkgdir}/MapTool-linux64-offline" "${pkgdir}/usr/bin/MapTool-linux64-offline"
+ install -Dm644 "$srcdir/MapTool.desktop" "${pkgdir}/usr/share/applications/MapTool.desktop"
+
+}