summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDirk Sohler2015-07-04 14:18:39 +0200
committerDirk Sohler2015-07-04 14:18:39 +0200
commit0cd6988f073a2c1ffad19cacf5b096d128689c78 (patch)
tree098a2016ea02580011f79e3328e77f7f1f938bcd
downloadaur-0cd6988f073a2c1ffad19cacf5b096d128689c78.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
-rw-r--r--mar.153
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11a00b30216a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mar-git
+ pkgdesc = An intuitive syntax mass file renamer
+ pkgver = 2.0.2
+ pkgrel = 2
+ url = http://dev.0x7be.de/mar.html
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python>=3.0
+ source = git://github.com/dsohler/mar.git#branch=master
+ source = mar.1
+ sha256sums = SKIP
+ sha256sums = 6b6fe3691becdd9e7750a2bc9f71042fbe65adeb44a8af5c5d1cf136cb783256
+
+pkgname = mar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ec6aca1918f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Dirk Sohler <spam@0x7be.de>
+# Maintainer: Dirk Sohler <spam@0x7be.de>
+# vim: ts=4:sw=4
+
+pkgname=mar-git
+_gitname=mar
+pkgver=2.0.2
+pkgrel=2
+pkgdesc='An intuitive syntax mass file renamer'
+
+url='http://dev.0x7be.de/mar.html'
+arch=('any')
+license=('GPL')
+
+depends=('python>=3.0')
+makedepends=('git')
+
+branch='master'
+
+source=("git://github.com/dsohler/mar.git#branch=$branch"
+ "mar.1")
+
+sha256sums=('SKIP'
+ '6b6fe3691becdd9e7750a2bc9f71042fbe65adeb44a8af5c5d1cf136cb783256')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(sed -n "s/^progversion = '\(.*\)'/\1/p" mar.py)
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -Dm 755 mar.py $pkgdir/usr/bin/mar
+ install -Dm 644 ../mar.1 $pkgdir/usr/share/man/man1/mar.1
+ gzip $pkgdir/usr/share/man/man1/mar.1
+}
diff --git a/mar.1 b/mar.1
new file mode 100644
index 000000000000..e50b552cdc2d
--- /dev/null
+++ b/mar.1
@@ -0,0 +1,53 @@
+.TH mar 1 "2013-08-25" 2.0.2
+.SH NAME
+mar - An intuitive syntax mass file renamer
+
+.SH SYNOPSIS
+.B mar
+.RB [\| -h \|]
+.RB [\| -n \|]
+.RB [\| -q \|]
+.RB [\| -b \|]
+.RB [\| \-s
+.IR N \|]
+.RB [\| -v \|]
+.IR mask
+.IR files
+
+.SH DESCRIPTION
+mar is a versy simple and intuitive file renaming tool with a very easy to learn syntax.
+
+.SH OPTIONS
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+show inline parameters help
+.TP
+\fB\-n\fR, \fB\-\-no\-colors\fR
+don't use colored output. Otherwise ANSI color codes will be used.
+.TP
+\fB\-q\fR, \fB\-\-quiet\fR
+don’t print status messages
+.TP
+\fB\-b\fR, \fB\-\-backup\fR
+create a CSV file containing old and new file names for easy recovery
+.TP
+\fB\-s\fR \fIN\fR, \fB\-\-start-with\fR=\fIN\fR
+by default numbering starts with 1. This sets starting number to N instead.
+.TP
+.TP
+\fB\-v\fR, \fB\-\-verboses\fR
+print additional runtime informations for debugging
+
+.SH USAGE
+\fImask\fR is a string containing every characters you want (please desist from using slashes. It MIGHT work for moving files, but I wouldn’t rely on it …) plus the string \fB%s\fR (… and right now you’ll not be able to use a literal %s, sorry). On file processing \fB%s\fR will be replaced with the current file’s number.
+
+\fIfiles\fR parameter is a list of files.
+
+.SH FULL DOCUMENTATION
+The full documentation of \fBmar\fR is available online at <http://dev.0x7be.de/mar.html>. In case of differences the documentation available online is to be looked upon as the more current version.
+
+.SH AUTHOR
+Dirk Sohler, <spam@0x7be.de>
+
+.SH SEE ALSO
+mycron(5), crontab(1)