summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2014-01-01 03:25:02 -0500
committerSlashbunny2014-01-01 03:28:54 -0500
commit94d31aebace483a75f60fff03a534006472ae6c6 (patch)
tree22f2f431f672422d12eff6cb0133d970cbd3aa47
parentef87c4115d976e06289e8a4d0bf101552bba5030 (diff)
downloadaur-94d31aebace483a75f60fff03a534006472ae6c6.tar.gz
/run is tmpfs, so tmpfiles.d configuration needs to be added to persist between reboots
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--maraschino.install2
-rw-r--r--tmpfiles.d1
4 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b880755b857e..97d0220deea6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = maraschinoproject-git
pkgdesc = Web-based frontend for XBMC, Sickbeard, Sabnzbd, and more.
pkgver = v0.3.0.r230.gf16c775
- pkgrel = 1
+ pkgrel = 2
url = http://www.maraschinoproject.com/
install = maraschino.install
arch = any
@@ -12,10 +12,12 @@ pkgbase = maraschinoproject-git
source = maraschino.sh
source = maraschino.confd
source = maraschino.service
+ source = tmpfiles.d
source = maraschino::git+https://github.com/mrkipling/maraschino.git
sha256sums = b711e56f3275aa2e600a737471e2f3d8adc0eb7452e7fbf0937cb4584f939e48
sha256sums = 2f9073c6cddd6a73a1f156c9280da757c8ea64c0134da70696705794a8d38aa5
sha256sums = 51d8698cac6b8a4d70e71aaa6bda1dbc071a3beb77557b3c5abfb33a78e63b6b
+ sha256sums = b66d6b0411d98bbee914ac2ab1bc7be1a4a1ab58580d948207be9114b3ac2890
sha256sums = SKIP
pkgname = maraschinoproject-git
diff --git a/PKGBUILD b/PKGBUILD
index 9cbcc732fee6..bf6099621cfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=maraschinoproject-git
pkgver=v0.3.0.r230.gf16c775
-pkgrel=1
+pkgrel=2
pkgdesc="Web-based frontend for XBMC, Sickbeard, Sabnzbd, and more."
arch=('any')
url="http://www.maraschinoproject.com/"
@@ -11,11 +11,12 @@ depends=('python2')
makedepends=('git')
backup=('etc/conf.d/maraschino')
install='maraschino.install'
-source=('maraschino.sh' 'maraschino.confd' 'maraschino.service'
+source=('maraschino.sh' 'maraschino.confd' 'maraschino.service' 'tmpfiles.d'
'maraschino::git+https://github.com/mrkipling/maraschino.git')
sha256sums=('b711e56f3275aa2e600a737471e2f3d8adc0eb7452e7fbf0937cb4584f939e48'
'2f9073c6cddd6a73a1f156c9280da757c8ea64c0134da70696705794a8d38aa5'
'51d8698cac6b8a4d70e71aaa6bda1dbc071a3beb77557b3c5abfb33a78e63b6b'
+ 'b66d6b0411d98bbee914ac2ab1bc7be1a4a1ab58580d948207be9114b3ac2890'
'SKIP')
pkgver() {
@@ -27,7 +28,6 @@ package() {
# Make destination directories
install -d "${pkgdir}/usr/lib"
install -d "${pkgdir}/var/lib/maraschino"
- install -dm777 "${pkgdir}/run/maraschino"
# Move Maraschino files to destination directory
cp -r "${srcdir}/maraschino" "${pkgdir}/usr/lib/maraschino"
@@ -43,5 +43,9 @@ package() {
# Install Daemon Configuration
install -D -m644 "${srcdir}/maraschino.confd" \
"${pkgdir}/etc/conf.d/maraschino"
+
+ # Install tempfiles.d Configuration
+ install -D -m644 "${srcdir}/tmpfiles.d" \
+ "${pkgdir}/usr/lib/tmpfiles.d/maraschino.conf"
}
diff --git a/maraschino.install b/maraschino.install
index f36f4e3beb60..29f0f874083f 100644
--- a/maraschino.install
+++ b/maraschino.install
@@ -9,6 +9,7 @@ post_install() {
useradd -g ${MC_GROUP} -d ${MC_DIR} -s /bin/false ${MC_USER} &> /dev/null
chown -R ${MC_USER}:${MC_GROUP} ${MC_DIR}
chown -R ${MC_USER}:${MC_GROUP} ${MC_SETTINGS_DIR}
+ usr/bin/systemd-tmpfiles --create maraschino.conf || true
}
## arg 1: the new package version
@@ -16,6 +17,7 @@ post_install() {
post_upgrade() {
chown -R ${MC_USER}:${MC_GROUP} ${MC_DIR}
chown -R ${MC_USER}:${MC_GROUP} ${MC_SETTINGS_DIR}
+ usr/bin/systemd-tmpfiles --create maraschino.conf || true
}
## arg 1: the old package version
diff --git a/tmpfiles.d b/tmpfiles.d
new file mode 100644
index 000000000000..7f3b2dcaf9b9
--- /dev/null
+++ b/tmpfiles.d
@@ -0,0 +1 @@
+d /run/maraschino 0755 maraschino maraschino