summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2024-03-30 05:21:40 +0000
committerJoão Figueiredo2024-03-30 05:21:40 +0000
commit7d543d4fe31e3e2b8e7b3533acb574fd0309ad28 (patch)
tree171bf0670d2fde46f8a0351cdb18575c1a311f51
parent4cc23d22d73bdab5bf7eedd8905517ff9b3c4561 (diff)
downloadaur-marble-git.tar.gz
Handle conflicts and provides properly
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9275571a85d8..6e41bd2da0ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = marble-git
pkgdesc = Desktop Globe
pkgver = 24.04.70_r13851.gab23c211a
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/KDE/marble
arch = x86_64
license = GPL-2.0-or-later
@@ -20,8 +20,6 @@ pkgbase = marble-git
makedepends = qt5-webengine
makedepends = shapelib
makedepends = kirigami2-git
- provides = marble
- conflicts = marble
source = git+https://github.com/KDE/marble.git
sha256sums = SKIP
@@ -43,6 +41,8 @@ pkgname = marble-git
depends = qt5-base
depends = qt5-declarative
optdepends = krunner5: Krunner plugin
+ provides = marble
+ conflicts = marble
pkgname = marble-common-git
pkgdesc = Common libraries and plugins for Marble
@@ -61,6 +61,8 @@ pkgname = marble-common-git
optdepends = libwlocate: WLAN based geolocation
optdepends = qt5-serialport: APRS plugin
optdepends = shapelib: SHP plugin
+ provides = marble-common
+ conflicts = marble-common
pkgname = marble-maps-git
pkgdesc = OpenStreetMap Navigation
@@ -70,6 +72,8 @@ pkgname = marble-maps-git
depends = marble-common-git
depends = qt5-base
depends = qt5-declarative
+ provides = marble-maps
+ conflicts = marble-maps
pkgname = marble-qt-git
pkgdesc = Desktop Globe (Qt version)
@@ -77,3 +81,5 @@ pkgname = marble-qt-git
depends = glibc
depends = marble-common-git
depends = qt5-base
+ provides = marble-qt
+ conflicts = marble-qt
diff --git a/PKGBUILD b/PKGBUILD
index 68a9c8a8b3f1..519e104ac53a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,12 @@ pkgname=(marble-git
marble-maps-git
marble-qt-git)
pkgver=24.04.70_r13851.gab23c211a
-pkgrel=1
+pkgrel=2
pkgdesc='Desktop Globe'
arch=($CARCH)
url="https://github.com/KDE/${pkgbase%-git}"
license=(GPL-2.0-or-later)
makedepends=(git extra-cmake-modules-git gpsd kdoctools5 knewstuff5 kparts5 krunner5 libwlocate phonon-qt5-git protobuf qt5-serialport qt5-tools qt5-webengine shapelib kirigami2-git)
-conflicts=(${pkgbase%-git})
-provides=(${pkgbase%-git})
source=("git+$url.git")
sha256sums=('SKIP')
@@ -44,6 +42,8 @@ build() {
package_marble-common-git() {
pkgdesc='Common libraries and plugins for Marble'
+ conflicts=(marble-common)
+ provides=(marble-common)
depends=(gcc-libs
glibc
phonon-qt5-git
@@ -71,6 +71,8 @@ package_marble-common-git() {
package_marble-qt-git() {
pkgdesc+=' (Qt version)'
+ conflicts=(marble-qt)
+ provides=(marble-qt)
depends=(gcc-libs
glibc
marble-common-git
@@ -94,6 +96,8 @@ package_marble-git() {
marble-common-git
qt5-base
qt5-declarative)
+ conflicts=(marble)
+ provides=(marble)
optdepends=('krunner5: Krunner plugin')
groups=(kde-applications-git
kde-education-git)
@@ -107,6 +111,8 @@ package_marble-git() {
package_marble-maps-git() {
pkgdesc='OpenStreetMap Navigation'
+ conflicts=(marble-maps)
+ provides=(marble-maps)
depends=(gcc-libs
glibc
kirigami2-git