summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-09-20 13:23:15 +0200
committersl1pkn072015-09-20 13:23:15 +0200
commit3ba7c39b0307ff0d2031010a6e7486f52d1f8859 (patch)
treec35eea56ec7b94b1be5b67e771c966e7fc928e58
parente7262592c94e7303371c9378c403d6332c917e6c (diff)
downloadaur-3ba7c39b0307ff0d2031010a6e7486f52d1f8859.tar.gz
Fixed (by upstream) designer plugins path
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13508364c850..ca36353984d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = marble-git
pkgdesc = Desktop Globe. (GIT version)
- pkgver = v15.08.0.161.g1db330f
+ pkgver = 1.11.80.r10804.f59d559
pkgrel = 1
url = https://www.kde.org/applications/system/marble
arch = i686
@@ -37,12 +37,11 @@ pkgname = marble-git
depends = kparts
depends = knewstuff
depends = opencv
+ depends = quazip-qt5
optdepends = gpsd: position information via gpsd
- optdepends = quazip-qt5: reading and displaying .kmz files
optdepends = shapelib: reading and displaying .shp files
optdepends = qextserialport-qt5: reading from serial port in APRS plugin
optdepends = libwlocate: Position information based on neighboring WLAN networks
- optdepends = phonon-qt5: That enables the use of audio and video content
optdepends = krunner: Krunner plugin for marble
conflicts = kdeedu-marble<15.04.3-3
conflicts = marble-qt
diff --git a/PKGBUILD b/PKGBUILD
index 8d2d5d79c6d9..453a161a1002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=marble-git
pkgname=('marble-git'
'libastro-git'
'marble-data-git')
-pkgver=v15.08.0.161.g1db330f
+pkgver=1.11.80.r10804.f59d559
pkgrel=1
pkgdesc="Desktop Globe. (GIT version)"
arch=('i686' 'x86_64')
@@ -34,15 +34,13 @@ sha1sums=('SKIP')
pkgver() {
cd marble
- echo "$(git describe --long --tags | tr - .)"
+ _ver="$(cat src/apps/marble-ui/ControlView.cpp | grep -m1 'return' | cut -d '"' -f2 | cut -d ' ' -f1)"
+ echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {
mkdir -p build
- # fix installation designer plugins path
- sed 's|${CMAKE_INSTALL_LIBDIR}/plugins|${CMAKE_INSTALL_LIBDIR}/qt/plugins|g' -i marble/CMakeLists.txt
-
# only build the KDE app
sed -e '/mobile/d' \
-e '/qt/d' \
@@ -60,6 +58,7 @@ build() {
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF \
-DWITH_KF5=ON \
+ -DQT_PLUGINS_DIR=lib/qt/plugins \
-DBUILD_MARBLE_EXAMPLES=ON \
-DBUILD_MARBLE_TOOLS=ON \
-DBUILD_MARBLE_TESTS=OFF \
@@ -85,13 +84,12 @@ package_marble-git() {
'kparts'
'knewstuff'
'opencv'
+ 'quazip-qt5'
)
optdepends=('gpsd: position information via gpsd'
- 'quazip-qt5: reading and displaying .kmz files'
'shapelib: reading and displaying .shp files'
'qextserialport-qt5: reading from serial port in APRS plugin'
'libwlocate: Position information based on neighboring WLAN networks'
- 'phonon-qt5: That enables the use of audio and video content'
'krunner: Krunner plugin for marble'
)
conflicts=('kdeedu-marble<15.04.3-3'