summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulioJu2016-05-29 17:48:09 +0200
committerJulioJu2016-05-29 17:48:09 +0200
commitb1e520adc6b1728ef5aa3bf7ab33eb9666fefdbf (patch)
treefa9c301e362f5aa554aeace6dc01ea46db9da451
parentbd9c8d0d01dbdc18d705aa08bfd5b0ef41cb5ce7 (diff)
downloadaur-b1e520adc6b1728ef5aa3bf7ab33eb9666fefdbf.tar.gz
Correr PKGBUILD errors, and delete wget
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dce9bc578dfd..e70c42426338 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,6 @@ pkgbase = marionnet
arch = i686
arch = x86_64
license = LGPL
- makedepends = wget
makedepends = optipng
depends = xorg-server
depends = xorg-xinit
diff --git a/PKGBUILD b/PKGBUILD
index 3b0bbafa2407..31fec9c3a290 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ users to define, configure and run complex computer networks without any need
for physical setup. Very old version."
arch=('i686' 'x86_64')
url="https://www.marionnet.org/"
-makedepends=('wget' 'optipng')
+makedepends=('optipng')
license=('LGPL')
depends=('xorg-server' 'xorg-xinit' 'xorg-server-utils' 'gtksourceview2' 'libglademm' 'graphviz' 'xterm' 'vde2' 'uml_utilities' 'net-tools' 'bridge-utils')
if test "$CARCH" == x86_64; then
@@ -75,8 +75,8 @@ build () {
if type uname 1>&2 && [[ $(uname -m) = "${CARCH}" ]]; then
local BUGFIX_FILE="bugfix-5237.diff"
echo "Downloading the ocaml 3.11 patch ($BUGFIX_FILE) for ${CARCH}"
- wget -O $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
- wget -O $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=415&type=bug' || \
+ curl -o $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
+ curl -o $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=415&type=bug' || \
return 1
echo "Applying the ocaml 3.11 patch ($BUGFIX_FILE) for ${CARCH}"
patch -p1 < $BUGFIX_FILE
@@ -85,8 +85,8 @@ build () {
elif type ld 1>&2 && ld -v | \grep -q '[ ]2[.]2[1-9]'; then
local BUGFIX_FILE="bugfix-5237-i386.diff"
echo "Downloading the ocaml 3.11 patch ($BUGFIX_FILE) for i386"
- wget -O $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
- wget -O $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=418&type=bug' || \
+ curl -o $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
+ curl -o $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=418&type=bug' || \
return 1
echo "Applying the ocaml 3.11 patch ($BUGFIX_FILE) for i386"
patch -p1 < $BUGFIX_FILE
@@ -139,7 +139,7 @@ EOF
# Makefile patch
- patch Makefile < ../Makefile.patch
+ patch Makefile < ../Makefile-legacy.patch
# Configure CONFIGME
cat > CONFIGME <<EOF