summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulioJu2016-05-29 21:31:39 +0200
committerJulioJu2016-05-29 21:31:39 +0200
commit428e145cc0215570f0deb584672b13c25bf79dc0 (patch)
tree82c2b2e1ab4b522a897849a64e0d10b06e741063
parent76dbd07f88edc9d7354aef6e2cc25bf353cba94c (diff)
downloadaur-428e145cc0215570f0deb584672b13c25bf79dc0.tar.gz
Add makedepend
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
-rw-r--r--marionnet_from_scratch-Downloader14
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5876ea6d9f0e..e32f5082c011 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = marionnet-trunk
arch = i686
arch = x86_64
license = LGPL
+ makedepends = bc
makedepends = optipng
depends = xorg-server
depends = xorg-xinit
diff --git a/PKGBUILD b/PKGBUILD
index 25dc93b8d423..e7a0dfc6c412 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ users to define, configure and run complex computer networks without any need
for physical setup. Trunk version (with UML kernel Debian Wheezy)."
arch=('i686' 'x86_64')
url="https://www.marionnet.org/"
-makedepends=('optipng')
+makedepends=('bc' 'optipng')
license=('LGPL')
depends=('xorg-server' 'xorg-xinit' 'xorg-server-utils' 'gtksourceview2' 'libglademm' 'graphviz' 'xterm' 'vde2' 'uml_utilities' 'net-tools' 'bridge-utils')
if test "$CARCH" == x86_64; then
diff --git a/marionnet_from_scratch-Downloader b/marionnet_from_scratch-Downloader
index 1d2261963634..c363d74d3ab1 100644
--- a/marionnet_from_scratch-Downloader
+++ b/marionnet_from_scratch-Downloader
@@ -164,7 +164,7 @@ fi
if [[ -n ${option_p} ]]; then
PREFIX=$(realpath "${option_p_arg}")
else
- PREFIX=$(realpath /usr/share)
+ PREFIX=$(realpath /usr/share/marionnet)
fi
# test version
@@ -271,11 +271,11 @@ OUR_TRUNK_SPECIFIC_URL="$OUR_BASE_URL/trunk"
function print_description_script {
echo -e " If the download is interrupted, it can be resumed by execute ${0##*/} who \
-is stored in $(realpath ./). This programm test if the hard disk have \
+is stored in $( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd ). This programm test if the hard disk have \
enough free space, if there isn't enough, it don't start download.
-Under ArchLinux, if Marionnet have been installed with Aur repository,
-files are extract in the good foler (i.e. /usr/share/marionnet). \
+Under ArchLinux, if Marionnet was installed with Aur repository,
+files are extracted in the good folder (i.e. /usr/share/marionnet). \
For other distributions, or if you have installed with the script « \
marionnet_from_scratch » customise the « --prefix » option. "
}
@@ -306,14 +306,14 @@ function freespace {
local FREE_MB=$(df -B 1M -P $PREFIX | awk '{print $4}' | tail -n 1)
if [[ $FREE_MB -lt $REQUIRED_MB ]]; then
echo "Insufficient free disk space (${FREE_MB} Mb) in the directory $PREFIX."
- echo "It's beautifule to have $REQUIRED_MB Mb to install and keep a little bit more space in your disk."
+ echo "It's beautifull to have $REQUIRED_MB Mb to install and keep a little bit more space in your disk."
echo "Exiting."
exit 1
fi 1>&2
}
# =============================================================
-# FUNCTIONS FOR DOWNLOADING OUR KERNELS AND FILESYSTEMS {{{1
+# FUNCTIONS FOR DOWNLOAD OUR KERNELS AND FILESYSTEMS {{{1
# =============================================================
function download_our_kernels {
@@ -457,7 +457,7 @@ else
stepPerformed=0
fi
if [[ ! $stepPerformed =~ ^[0-9]$ ]] ; then
- echo "Invalid step readen. Restart downloading"
+ echo "Invalid step readen. Restart the download"
stepPerformed=0
fi