summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-15 22:53:38 +0100
committerCarl Smedstad2024-01-15 22:53:38 +0100
commit9709645dd3116dc04b0110b55813b3de02df38a8 (patch)
tree98e8708c15c2c74125bb9a11b28f6bae33ea51dc
parentbfd1d131a8a4a60279beee0273d7f7f95d76e73f (diff)
downloadaur-9709645dd3116dc04b0110b55813b3de02df38a8.tar.gz
upgpkg: markdown-link-check 3.11.2-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce9e2e16d2fa..68ee312ebb88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = markdown-link-check
pkgdesc = Checks aliveness of hyperlinks in markdown documents
pkgver = 3.11.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tcort/markdown-link-check
arch = any
- license = custom:ICS
+ license = ISC
makedepends = npm
depends = nodejs
noextract = markdown-link-check-3.11.2.tgz
diff --git a/PKGBUILD b/PKGBUILD
index dc60ae32e181..72f402be0c62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=markdown-link-check
pkgver=3.11.2
-pkgrel=1
+pkgrel=2
pkgdesc="Checks aliveness of hyperlinks in markdown documents"
arch=(any)
url="https://github.com/tcort/markdown-link-check"
-license=(custom:ICS)
+license=(ISC)
depends=(nodejs)
makedepends=(npm)
@@ -15,15 +15,15 @@ noextract=("$pkgname-$pkgver.tgz")
sha256sums=('49d9933f4f544446c1d3359b704200d22f8689b2000d21374a8bbf063c9366fb')
package() {
- npm install -g \
- --cache "$srcdir/npm-cache" \
- --prefix "$pkgdir/usr" \
- "$srcdir/$pkgname-$pkgver.tgz"
- install -Dm644 \
- "$pkgdir/usr/lib/node_modules/$pkgname/LICENSE.md" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ npm install -g \
+ --cache "$srcdir/npm-cache" \
+ --prefix "$pkgdir/usr" \
+ "$srcdir/$pkgname-$pkgver.tgz"
- # npm gives ownership of ALL FILES to build user
- # https://bugs.archlinux.org/task/63396
- chown -R root:root "$pkgdir"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" \
+ "$pkgdir/usr/lib/node_modules/$pkgname/LICENSE.md"
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "$pkgdir"
}