summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2022-03-15 10:54:02 +0100
committerCarl Smedstad2022-03-15 11:41:38 +0100
commitb8db57771c275e44378ddcbd7f661952cecde6c6 (patch)
tree894a29b0dbaec06f3ca51e3f79d3ced17c9778d8
downloadaur-b8db57771c275e44378ddcbd7f661952cecde6c6.tar.gz
Initial package - version 3.9.3
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea793449baea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = markdown-link-check
+ pkgdesc = checks that all of the hyperlinks in a markdown text to determine if they are alive or dead
+ pkgver = 3.9.3
+ pkgrel = 1
+ url = https://github.com/tcort/markdown-link-check
+ arch = any
+ license = ICS
+ makedepends = npm
+ noextract = markdown-link-check-3.9.3.tgz
+ source = https://registry.npmjs.org/markdown-link-check/-/markdown-link-check-3.9.3.tgz
+ sha256sums = 9c1f0ebc30661523e0093e8100c78da2bbe8676f3e601b1abc146f949f243b0c
+
+pkgname = markdown-link-check
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..630b80c78e53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+
+pkgname=markdown-link-check
+pkgver=3.9.3
+pkgrel=1
+pkgdesc="checks that all of the hyperlinks in a markdown text to determine if they are alive or dead"
+arch=('any')
+url="https://github.com/tcort/markdown-link-check"
+license=('ICS')
+makedepends=('npm')
+
+source=("https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
+noextract=("$pkgname-$pkgver.tgz")
+sha256sums=('9c1f0ebc30661523e0093e8100c78da2bbe8676f3e601b1abc146f949f243b0c')
+
+package() {
+ npm install -g \
+ --cache "$srcdir/npm-cache" \
+ --prefix "$pkgdir/usr" \
+ "$srcdir/$pkgname-$pkgver.tgz"
+ install -Dm644 \
+ "$pkgdir/usr/lib/node_modules/$pkgname/LICENSE.md" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "$pkgdir"
+}