summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdJoPaTo2021-05-08 23:47:44 +0200
committerEdJoPaTo2021-05-08 23:47:44 +0200
commit0b2a6b1ec5a91ac9ba3661fb75fa175efbf532f5 (patch)
tree81db53f9ab32735bcb39a8fad832b82d07f61ce1
downloadaur-0b2a6b1ec5a91ac9ba3661fb75fa175efbf532f5.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD27
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..096744b1ddd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = markdown-to-standalone-html
+ pkgdesc = Create a standalone HTML file from Markdown with basic CSS, table of contents and source code highlighting
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/EdJoPaTo/markdown-to-standalone-html
+ arch = x86_64
+ arch = aarch64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = cargo
+ optdepends = monolith: inline assets like images or CSS
+ provides = markdown-to-standalone-html
+ conflicts = markdown-to-standalone-html
+ source = markdown-to-standalone-html-0.4.1.tar.gz::https://github.com/EdJoPaTo/markdown-to-standalone-html/archive/v0.4.1.tar.gz
+ sha256sums = e2a3672cbacfef374f84717147b224d18e1fde177ae08085840463aa7f260fef
+
+pkgname = markdown-to-standalone-html
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7f97a6eff873
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73bde5b14cf4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=markdown-to-standalone-html
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Create a standalone HTML file from Markdown with basic CSS, table of contents and source code highlighting"
+arch=('x86_64' 'aarch64' 'armv6h' 'armv7h')
+url="https://github.com/EdJoPaTo/markdown-to-standalone-html"
+license=('MIT')
+depends=()
+makedepends=('cargo')
+optdepends=('monolith: inline assets like images or CSS')
+provides=("markdown-to-standalone-html")
+conflicts=("markdown-to-standalone-html")
+
+source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
+sha256sums=('e2a3672cbacfef374f84717147b224d18e1fde177ae08085840463aa7f260fef')
+
+build() {
+ cd $pkgname-$pkgver
+ cargo build --release
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm 755 target/release/$pkgname -t "$pkgdir"/usr/bin
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+}