summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2018-01-20 02:21:09 +0100
committerJosip Ponjavic2018-01-20 02:21:09 +0100
commitf1057dcfe13ad437ee3743c48a1f6f91db955a21 (patch)
treeec1b6cfe6b808d0b0acd73053ac1d2bff67f4c7b
downloadaur-f1057dcfe13ad437ee3743c48a1f6f91db955a21.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a62b52b2f97e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = marker
+ pkgdesc = Markdown editor for linux made with Gtk+-3.0
+ pkgver = 2018.01.09
+ pkgrel = 1
+ url = https://github.com/fabiocolacio/Marker
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ depends = gtksourceview3
+ depends = gtkspell3
+ depends = webkit2gtk
+ optdepends = pandoc: export to HTML, PDF, RTF, OTF, DOCX, LaTeX
+ source = marker-2018.01.09.tar.gz::https://github.com/fabiocolacio/Marker/archive/2018.01.09.tar.gz
+ sha256sums = bd8b074ca5c1cdb4d85186b0a5d7d78e6880fcb4fba710a69b5f55194dd2d6be
+
+pkgname = marker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2140a81a6dfb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+# Contributor:
+
+pkgname=marker
+pkgver=2018.01.09
+pkgrel=1
+pkgdesc='Markdown editor for linux made with Gtk+-3.0'
+arch=('x86_64')
+url='https://github.com/fabiocolacio/Marker'
+license=('GPL3')
+depends=('gtksourceview3' 'gtkspell3' 'webkit2gtk')
+makedepends=('meson')
+optdepends=('pandoc: export to HTML, PDF, RTF, OTF, DOCX, LaTeX')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('bd8b074ca5c1cdb4d85186b0a5d7d78e6880fcb4fba710a69b5f55194dd2d6be')
+
+prepare() {
+ sed -e '/^meson.add_install_script/ s/^#*/#/' -i Marker-$pkgver/meson.build
+}
+
+build() {
+ cd Marker-$pkgver
+ meson --prefix=/usr build
+ ninja -C build
+}
+
+package() {
+ cd Marker-$pkgver
+ DESTDIR="$pkgdir" ninja install -C build
+}