summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-11-03 15:13:03 -0600
committerMark Wagie2023-11-03 15:13:03 -0600
commit01b3b18aa2958d4a4d89b0513b8a5ffcf3601835 (patch)
tree2dfa716e5901a1c0852402da7abe6303adf897dc
parent1b02015dc23a311f07ec1b3d7513420892ce7db8 (diff)
downloadaur-01b3b18aa2958d4a4d89b0513b8a5ffcf3601835.tar.gz
fix build
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
-rw-r--r--add_gi18n_h.patch13
4 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 398406ae66b5..56118b6f08d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = marker-git
pkgdesc = Markdown editor for linux made with Gtk+-3.0
pkgver = 2023.05.02.r11.gae508ff7
pkgrel = 1
- url = https://fabiocolacio.github.io/Marker/
+ url = https://fabiocolacio.github.io/Marker
arch = x86_64
license = GPL3
checkdepends = appstream-glib
@@ -19,9 +19,11 @@ pkgbase = marker-git
source = git+https://github.com/Mandarancio/scidown.git
source = git+https://github.com/Mandarancio/charter.git
source = git+https://github.com/codeplea/tinyexpr.git
+ source = add_gi18n_h.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = a549a622d3d58936643f4932235711c03a38550d09266e1863a936e41618b661
pkgname = marker-git
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..bac272874b48 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!add_gi18n_h.patch
diff --git a/PKGBUILD b/PKGBUILD
index 2c5b7e2796dc..b7d02a58fad5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver=2023.05.02.r11.gae508ff7
pkgrel=1
pkgdesc="Markdown editor for linux made with Gtk+-3.0"
arch=('x86_64')
-url='https://fabiocolacio.github.io/Marker/'
+url="https://fabiocolacio.github.io/Marker"
license=('GPL3')
depends=('gtksourceview3' 'gtkspell3' 'webkit2gtk-4.1')
makedepends=('git' 'itstool' 'meson')
@@ -16,11 +16,13 @@ conflicts=("${pkgname%-*}")
source=('git+https://github.com/fabiocolacio/Marker.git'
'git+https://github.com/Mandarancio/scidown.git'
'git+https://github.com/Mandarancio/charter.git'
- 'git+https://github.com/codeplea/tinyexpr.git')
+ 'git+https://github.com/codeplea/tinyexpr.git'
+ 'add_gi18n_h.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'a549a622d3d58936643f4932235711c03a38550d09266e1863a936e41618b661')
pkgver() {
cd Marker
@@ -33,6 +35,11 @@ prepare() {
git config submodule.src/scidown.url "$srcdir/scidown"
git -c protocol.file.allow=always submodule update
+ # Update version
+ sed -i "s/2020.04.04/${pkgver%%.r*}/g" meson.build
+
+ patch -Np1 -i ../add_gi18n_h.patch
+
cd src/scidown
git submodule init
git config submodule.src/charter.url "$srcdir/charter"
diff --git a/add_gi18n_h.patch b/add_gi18n_h.patch
new file mode 100644
index 000000000000..189ef7585fd2
--- /dev/null
+++ b/add_gi18n_h.patch
@@ -0,0 +1,13 @@
+diff --git a/src/marker.h b/src/marker.h
+index 334bc32a..fda32735 100644
+--- a/src/marker.h
++++ b/src/marker.h
+@@ -23,7 +23,7 @@
+ #define __MARKER_H__
+
+ #include <gtk/gtk.h>
+-
++#include <glib/gi18n.h>
+ GtkApplication *marker_get_app (void);
+ void marker_create_new_window (void);
+ void marker_create_new_window_from_file (GFile *file);