summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-11-02 10:09:03 -0600
committerMark Wagie2023-11-02 10:09:03 -0600
commit1b02015dc23a311f07ec1b3d7513420892ce7db8 (patch)
treeab97fc50d8c93bcd8be85b4dfb31abd168689e4c
parent79435bde96eda8bf1bb27a84e870361cbc641ea2 (diff)
downloadaur-1b02015dc23a311f07ec1b3d7513420892ce7db8.tar.gz
adopt package
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD56
3 files changed, 56 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4dea168d8d1f..398406ae66b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,27 @@
pkgbase = marker-git
pkgdesc = Markdown editor for linux made with Gtk+-3.0
- pkgver = 2020.04.04.2.r82.g73b4c484
+ pkgver = 2023.05.02.r11.gae508ff7
pkgrel = 1
url = https://fabiocolacio.github.io/Marker/
arch = x86_64
license = GPL3
+ checkdepends = appstream-glib
makedepends = git
makedepends = itstool
makedepends = meson
depends = gtksourceview3
depends = gtkspell3
- depends = webkit2gtk
+ depends = webkit2gtk-4.1
optdepends = pandoc: export to HTML, PDF, RTF, OTF, DOCX, LaTeX
provides = marker
conflicts = marker
- options = !buildflags
- source = marker::git+https://github.com/fabiocolacio/Marker.git
+ source = git+https://github.com/fabiocolacio/Marker.git
+ source = git+https://github.com/Mandarancio/scidown.git
+ source = git+https://github.com/Mandarancio/charter.git
+ source = git+https://github.com/codeplea/tinyexpr.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = marker-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 5b30b3f0bfc2..2c5b7e2796dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,60 @@
-# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
-# Contributor:
-
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+# Contributor: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=marker-git
-pkgver=2020.04.04.2.r82.g73b4c484
+pkgver=2023.05.02.r11.gae508ff7
pkgrel=1
-pkgdesc='Markdown editor for linux made with Gtk+-3.0'
+pkgdesc="Markdown editor for linux made with Gtk+-3.0"
arch=('x86_64')
url='https://fabiocolacio.github.io/Marker/'
license=('GPL3')
-depends=('gtksourceview3' 'gtkspell3' 'webkit2gtk')
+depends=('gtksourceview3' 'gtkspell3' 'webkit2gtk-4.1')
makedepends=('git' 'itstool' 'meson')
+checkdepends=('appstream-glib')
optdepends=('pandoc: export to HTML, PDF, RTF, OTF, DOCX, LaTeX')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-options=(!buildflags)
-source=("${pkgname%-*}::git+https://github.com/fabiocolacio/Marker.git")
-sha256sums=('SKIP')
+source=('git+https://github.com/fabiocolacio/Marker.git'
+ 'git+https://github.com/Mandarancio/scidown.git'
+ 'git+https://github.com/Mandarancio/charter.git'
+ 'git+https://github.com/codeplea/tinyexpr.git')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd ${pkgname%-*}
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd Marker
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {
- cd ${pkgname%-*}
- git submodule update --init --recursive
- ln -sv ../../po/uk.po help/uk/uk.po
+ cd Marker
+ git submodule init
+ git config submodule.src/scidown.url "$srcdir/scidown"
+ git -c protocol.file.allow=always submodule update
+
+ cd src/scidown
+ git submodule init
+ git config submodule.src/charter.url "$srcdir/charter"
+ git -c protocol.file.allow=always submodule update
+
+ cd src/charter
+ git submodule init
+ git config submodule.src/tinyexpr.url "$srcdir/tinyexpr"
+ git -c protocol.file.allow=always submodule update
}
build() {
- arch-meson ${pkgname%-*} build
- ninja -C build
+ arch-meson Marker build
+ meson compile -C build
+}
+
+check() {
+ cd Marker
+ appstream-util validate-relax --nonet data/*.appdata.xml
+ desktop-file-validate data/*.desktop
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ meson install -C build --destdir "$pkgdir"
}