summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnonymerNiklasistanonym2020-08-08 18:32:50 +0200
committerAnonymerNiklasistanonym2020-08-08 18:32:50 +0200
commitfbf768d6038f2dda5b6dcecbe5017b36ad20d2e4 (patch)
tree6ac99a7d21a9d7fcd2d6f63772b2e00a8743bf08
parent7422218275c2051937ed1aee9992154ddc99fe8e (diff)
downloadaur-fbf768d6038f2dda5b6dcecbe5017b36ad20d2e4.tar.gz
Decrease install size using make dependency node-prune
Pamac reports 51MB to 34MB decrease
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e139f83c1757..ad10610cf560 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = marktex
pkgdesc = Web service for files that support advanced Markdown commands mixed with LaTeX sections
pkgver = 1.0.1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/AnonymerNiklasistanonym/MarkTeX
arch = x86_64
license = MIT
+ makedepends = node-prune
depends = nodejs
depends = inkscape
depends = pandoc
diff --git a/PKGBUILD b/PKGBUILD
index 7c2857312d4e..65e4a1a32087 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: AnonymerNiklasistanonym <niklas.mikeler@gmail.com>
pkgname=marktex
pkgver=1.0.1
-pkgrel=5
+pkgrel=6
pkgdesc='Web service for files that support advanced Markdown commands mixed with LaTeX sections'
arch=('x86_64')
url='https://github.com/AnonymerNiklasistanonym/MarkTeX'
license=('MIT')
depends=('nodejs' 'inkscape' 'pandoc' 'texlive-core')
+makedepends=('node-prune')
provides=("$pkgname")
conflicts=("$pkgname")
_gitname="$pkgname.git"
@@ -17,8 +18,11 @@ build() {
cd "$_gitname" || exit 1
npm install
npm run build
+ # Remove dev depdencies and only install production depdencies for deployment
rm -rf node_modules
npm install --only=production
+ # Remove unnecessary files from node_modules
+ node-prune
}
package() {