summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Birks2019-05-15 06:50:49 -0400
committerDavid Birks2019-05-15 06:50:49 -0400
commite2c28c0a7357dc63b900e981c1e8f177612b7293 (patch)
tree3a110d9813e6f4892e0056333574ae464c997752
parent28cf823fec95a0cd40a04153e9e202d5c14a83c4 (diff)
downloadaur-e2c28c0a7357dc63b900e981c1e8f177612b7293.tar.gz
Change to my PKGBUILD preferences
Remove unneeded licenses
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD26
2 files changed, 12 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34875b1116e2..3e8566a2c2a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = marktext
- pkgdesc = Next generation markdown editor
+ pkgdesc = A simple and elegant open-source markdown editor that focused on speed and usability
pkgver = 0.14.0
pkgrel = 1
url = https://github.com/marktext/marktext
- arch = x86
arch = x86_64
license = MIT
makedepends = yarn
depends = gtk3
depends = libxss
depends = nss
+ conflicts = marktext-bin
+ conflicts = marktext-git
source = marktext-0.14.0.tar.gz::http://github.com/marktext/marktext/archive/v0.14.0.tar.gz
sha512sums = 11249a2b350a973dd4e35c6f1bedf61415c6e49e22f8e344a4e3f942244cfea5d587adfe7f472e26696ab7e91fc5f17337e6de5db32de2ced964dadd5907c003
diff --git a/PKGBUILD b/PKGBUILD
index 63a46c09a90d..df4395ea5404 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,35 @@
-# Maintainer: Simon Doppler (dopsi) <dop.simon@gmail.com>
-# Co-maintainer: David Birks <david@tellus.space>
-# Contributor: dpeukert
+# Maintainer: David Birks <david@tellus.space>
pkgname=marktext
pkgver=0.14.0
pkgrel=1
-pkgdesc='Next generation markdown editor'
-arch=('x86' 'x86_64')
+pkgdesc='A simple and elegant open-source markdown editor that focused on speed and usability'
+arch=('x86_64')
url='https://github.com/marktext/marktext'
license=('MIT')
+conflicts=('marktext-bin' 'marktext-git')
depends=('gtk3' 'libxss' 'nss')
makedepends=('yarn')
-source=("${pkgname}-${pkgver}.tar.gz::http://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::http://github.com/marktext/marktext/archive/v$pkgver.tar.gz")
sha512sums=('11249a2b350a973dd4e35c6f1bedf61415c6e49e22f8e344a4e3f942244cfea5d587adfe7f472e26696ab7e91fc5f17337e6de5db32de2ced964dadd5907c003')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "$srcdir/$pkgname-$pkgver"
yarn install
yarn build:dir
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "$srcdir/$pkgname-$pkgver"
install -d "$pkgdir/usr/lib"
cp -r "build/linux-unpacked" "$pkgdir/usr/lib/$pkgname"
# Symlink main binary
- install -d "${pkgdir}/usr/bin"
- ln -s "/usr/lib/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
-
- # Install license file
- install -D LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
- install -D build/linux-unpacked/LICENSE.electron.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.electron.txt"
- install -D build/linux-unpacked/LICENSES.chromium.html "$pkgdir/usr/share/licenses/$pkgname/LICENSES.chromium.html"
+ install -d "$pkgdir/usr/bin"
+ ln -s "/usr/lib/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
# Install desktop file and icon
install -D "resources/linux/marktext.desktop" "$pkgdir/usr/share/applications/marktext.desktop"
install -D "resources/icons/icon.png" "$pkgdir/usr/share/pixmaps/marktext.png"
}
-
-# vim:ts=4:sw=4:expandtab