summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-06-29 22:00:36 +0300
committerCaleb Maclennan2020-06-29 22:00:36 +0300
commit919fbfd4e059c450f353a061165e494231843839 (patch)
tree2d739128dc6563f5ef31221e2576902646318a41
parentbbd6ee71bf0f54ec895e84479a5a13bbe6d20ae6 (diff)
downloadaur-919fbfd4e059c450f353a061165e494231843839.tar.gz
upgpkg: marktext-git 0.16.2.r0.g1e7ff90-1
upstream release Build with Electron 7 to avoid runtime forever-loop
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--marktext.sh2
3 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53e3e7d37e3c..c98bb11e5346 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = marktext-git
pkgdesc = A simple and elegant open-source markdown editor that focused on speed and usability
- pkgver = 0.16.0.r6.g90fdd28
+ pkgver = 0.16.2.r0.g1e7ff90
pkgrel = 1
url = https://marktext.app
arch = x86_64
@@ -11,17 +11,17 @@ pkgbase = marktext-git
makedepends = moreutils
makedepends = yarn
makedepends = yq
- depends = electron
+ depends = electron7
depends = libxkbfile
depends = libsecret
depends = ripgrep
- provides = marktext-0.16.0.r6.g90fdd28
+ provides = marktext-0.16.2.r0.g1e7ff90
conflicts = marktext
source = marktext-git::git+https://github.com/marktext/marktext.git
source = marktext.sh
source = marktext-arg-handling.patch
sha256sums = SKIP
- sha256sums = c5af6eabe525af458df2ccfac6098092746dd0ae23225c131100bb6e37170f86
+ sha256sums = 15a964fcc3f6bd7bf1c03566d35201032aecde994446533cad1f810e9b880f14
sha256sums = c754a1cad52d10a38eeddb9293ce0a4540296c6adbb47eb5311eaaeded150a01
pkgname = marktext-git
diff --git a/PKGBUILD b/PKGBUILD
index 59ae944ba1e0..6829b7b7e942 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
-# Maintainer: Gabriel Saillard (GitSquared) <gabriel@saillard.dev>
+# Contributor: Gabriel Saillard (GitSquared) <gabriel@saillard.dev>
# Contributor: David Birks <david@tellus.space>
# Contributor: Simon Doppler (dopsi) <dop.simon@gmail.com>
# Contributor: dpeukert
@@ -7,13 +7,13 @@
pkgname=marktext-git
_pkgname=${pkgname%-git}
-pkgver=0.16.0.r6.g90fdd28
+pkgver=0.16.2.r0.g1e7ff90
pkgrel=1
pkgdesc='A simple and elegant open-source markdown editor that focused on speed and usability'
arch=('x86_64')
url='https://marktext.app'
license=('MIT')
-depends=('electron'
+depends=('electron7'
'libxkbfile'
'libsecret'
'ripgrep')
@@ -29,19 +29,18 @@ source=("$pkgname::git+https://github.com/$_pkgname/${pkgname/-/.}"
"$_pkgname.sh"
"$_pkgname-arg-handling.patch")
sha256sums=('SKIP'
- 'c5af6eabe525af458df2ccfac6098092746dd0ae23225c131100bb6e37170f86'
+ '15a964fcc3f6bd7bf1c03566d35201032aecde994446533cad1f810e9b880f14'
'c754a1cad52d10a38eeddb9293ce0a4540296c6adbb47eb5311eaaeded150a01')
-_electronDist=$(dirname $(realpath $(which electron)))
-_electronVersion=$(electron --version | sed -e 's/^v//')
-
pkgver() {
cd "$pkgname"
- git describe --tags --abbrev=7 --match="v*" HEAD |
+ git describe --long --tags --abbrev=7 --match="v*" HEAD |
sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
+ local _electronDist=$(dirname $(realpath $(which electron7)))
+ local _electronVersion=$(electron7 --version | sed -e 's/^v//')
cd "$pkgname"
jq 'del(.devDependencies["electron"], .scripts["preinstall", "postinstall"])' \
package.json | sponge package.json
diff --git a/marktext.sh b/marktext.sh
index 8bfc08fdf0ed..93fa48d9cc47 100644
--- a/marktext.sh
+++ b/marktext.sh
@@ -1,3 +1,3 @@
#!/usr/bin/env sh
-exec electron /usr/lib/marktext/app.asar "$@"
+exec electron7 /usr/lib/marktext/app.asar "$@"