summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2019-10-25 23:27:33 +0200
committerSebastiaan Lokhorst2019-10-25 23:27:33 +0200
commita33b2610b9432bb89e90a3afa225ab866ed6c1b7 (patch)
tree64884cc3727588f3ce1359ad97daa182bf7e5e0d
parentcf3d535ec29e51b395185fbe385666cb83e26413 (diff)
downloadaur-a33b2610b9432bb89e90a3afa225ab866ed6c1b7.tar.gz
Add conflicts and provides; fix file location
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69fe1b070cc0..e016b4dbd7ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,8 @@ pkgbase = marktext-git
makedepends = npm
makedepends = yarn
depends = electron
+ provides = marktext
+ conflicts = marktext
source = git+https://github.com/marktext/marktext
source = marktext.sh
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 15bb402f891c..fb9c6f059487 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,8 @@ url='https://marktext.github.io/website/'
license=('MIT')
depends=('electron')
makedepends=('python' 'nodejs' 'npm' 'yarn')
+conflicts=('marktext')
+provides=('marktext')
source=("git+https://github.com/${_gitname}/${_gitname}"
'marktext.sh')
sha512sums=('SKIP'
@@ -37,14 +39,14 @@ package() {
# Install app.asar and launcher script
install -D build/linux-unpacked/resources/app.asar "${pkgdir}/usr/share/marktext/app.asar"
- install -D "${srcdir}/marktext.sh" "${pkgdir}/usr/bin/$pkgname"
+ install -D "${srcdir}/marktext.sh" "${pkgdir}/usr/bin/marktext"
# Install desktop file and icon
install -D resources/linux/marktext.desktop "${pkgdir}/usr/share/applications/marktext.desktop"
install -D resources/icons/icon.png "${pkgdir}/usr/share/pixmaps/marktext.png"
# Install license file
- install -D LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
- install -D build/linux-unpacked/LICENSE.electron.txt "${pkgdir}/usr/share/licenses/$pkgname/LICENSE.electron.txt"
- install -D build/linux-unpacked/LICENSES.chromium.html "${pkgdir}/usr/share/licenses/$pkgname/LICENSES.chromium.html"
+ install -D LICENSE "${pkgdir}/usr/share/licenses/marktext/LICENSE"
+ install -D build/linux-unpacked/LICENSE.electron.txt "${pkgdir}/usr/share/licenses/marktext/LICENSE.electron.txt"
+ install -D build/linux-unpacked/LICENSES.chromium.html "${pkgdir}/usr/share/licenses/marktext/LICENSES.chromium.html"
}