summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:10:51 -0600
committernot_anonymous2015-07-05 18:10:51 -0600
commit2377c249b210865a8054e4cc1d836d55817a341f (patch)
tree349d4fe9a36a3a20b441e4c9101a76e646fb527e
downloadaur-2377c249b210865a8054e4cc1d836d55817a341f.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
-rw-r--r--marote.desktop16
-rw-r--r--marote.install11
-rw-r--r--marote.pngbin0 -> 3753 bytes
5 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29bff76c1540
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = marote
+ pkgdesc = Rig conrol program for Elecraft K2 Transceiver
+ pkgver = 3.1
+ pkgrel = 2
+ url = http://hamsoftware.org/old_index.html
+ install = marote.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt3
+ depends = desktop-file-utils
+ optdepends = xlog: logbook
+ source = http://www.hamsoftware.org/marote-3.1.tgz
+ source = marote.desktop
+ source = marote.png
+ md5sums = 2848d998f971bc836463da231ff7759d
+ md5sums = 18b8d7c22a960ca6c2cd1868140f8af5
+ md5sums = ba79c00f4e68bd67062c7616f9349620
+ sha256sums = 2d9953828a888de3737c407b74d4bdfcf8dbf70b111acfce4db721ed1b608639
+ sha256sums = 935ab0354b34b58efc1cb4e71044b46f868975e719a20e4d556e9228240ca137
+ sha256sums = 48bbab2e8c3affd34ed22d97d8b24f49974aa3bacbdfabe91e3363e9d2bb8678
+
+pkgname = marote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..049d5cb39b3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+# Contributor: Bob Finch <w9ya@qrparci.net>
+
+pkgname=marote
+pkgver=3.1
+pkgrel=2
+pkgdesc="Rig conrol program for Elecraft K2 Transceiver"
+arch=('i686' 'x86_64')
+url="http://hamsoftware.org/old_index.html"
+license=('GPL')
+depends=('qt3' 'desktop-file-utils')
+optdepends=('xlog: logbook')
+install=$pkgname.install
+source=(http://www.hamsoftware.org/$pkgname-$pkgver.tgz
+ $pkgname.desktop
+ $pkgname.png)
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ /usr/lib/qt3/bin/qmake marote.pro
+ sed -i s:'\$(QTDIR)\/include':'\/usr\/include\/qt3': Makefile
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ make MOC=/usr/lib/qt3/bin/moc UIC=/usr/lib/qt3/bin/uic || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/"
+
+ sed -i 's:\/local::g' Makefile
+ make INSTALL_ROOT="$pkgdir/" install
+
+ install -Dm644 README $pkgdir/usr/share/$pkgname/docs/README.txt
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $srcdir/$pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+}
+md5sums=('2848d998f971bc836463da231ff7759d'
+ '18b8d7c22a960ca6c2cd1868140f8af5'
+ 'ba79c00f4e68bd67062c7616f9349620')
+sha256sums=('2d9953828a888de3737c407b74d4bdfcf8dbf70b111acfce4db721ed1b608639'
+ '935ab0354b34b58efc1cb4e71044b46f868975e719a20e4d556e9228240ca137'
+ '48bbab2e8c3affd34ed22d97d8b24f49974aa3bacbdfabe91e3363e9d2bb8678')
diff --git a/marote.desktop b/marote.desktop
new file mode 100644
index 000000000000..490114215018
--- /dev/null
+++ b/marote.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=Marote
+Name[en_US]=Marote
+Comment=Elecraft K2 Tranciever Control - Interops with Xlog
+Comment[en_US]=Elecraft K2 Tranciever Control - Interops with Xlog
+Encoding=UTF-8
+Exec=marote
+Icon=marote.png
+MimeType=text/plain
+StartupNotify=true
+Terminal=
+TerminalOptions=
+Type=Application
+Categories=Application;HamRadio;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/marote.install b/marote.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/marote.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/marote.png b/marote.png
new file mode 100644
index 000000000000..46e08cc42dfd
--- /dev/null
+++ b/marote.png
Binary files differ