summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthijs Tadema2019-06-05 13:51:14 +0200
committerMatthijs Tadema2019-06-05 13:56:38 +0200
commit01d811b91d33d036b19e9920b43b0ea2a7db2f74 (patch)
tree0d4ba2d73d34c299bec5c86bff56b854fe4a814c
downloadaur-01d811b91d33d036b19e9920b43b0ea2a7db2f74.tar.gz
Initial package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..684cef12827e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = martinize-git
+ pkgdesc = Describe and apply transformation on molecular structures and topologies
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/marrink-lab/vermouth-martinize
+ arch = any
+ license = Apache
+ makedepends = python>=3.5
+ depends = python>=3.5
+ source = martinize-git_0.1.0::git+https://github.com/marrink-lab/vermouth-martinize.git
+ md5sums = SKIP
+
+pkgname = martinize-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1fcb7923f72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Matthijs Tadema <M dot J dot Tadema at protonmail dot com>
+
+pkgname=martinize-git
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Describe and apply transformation on molecular structures and topologies"
+arch=('any')
+url="https://github.com/marrink-lab/vermouth-martinize"
+license=('Apache')
+depends=('python>=3.5')
+makedepends=('python>=3.5')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}_${pkgver}::git+https://github.com/marrink-lab/vermouth-martinize.git")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+package() {
+ cd ${pkgname}_${pkgver}
+ /usr/bin/env python3 setup.py install --prefix="$pkgdir/usr/"
+}