summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Gaifas2019-12-10 12:44:34 +0100
committerLorenzo Gaifas2019-12-10 12:44:34 +0100
commit18b8a0a8481bef1c1ce8687845517e7ac52a6589 (patch)
treef65df250b885f8f6f0f971c00a7f5779869e0a43
parent8efa550a06882e2c7039d2d08898ec32b4625a82 (diff)
downloadaur-18b8a0a8481bef1c1ce8687845517e7ac52a6589.tar.gz
updaded versioning, added deps
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 25 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8f0fbe488e9..272871f21334 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,18 @@
pkgbase = martinize-git
pkgdesc = Describe and apply transformation on molecular structures and topologies
- pkgver = 0.1.0
+ pkgver = v0.3.1.r8.2a50f80
pkgrel = 1
url = https://github.com/marrink-lab/vermouth-martinize
arch = any
license = Apache
depends = python>=3.5
- source = martinize-git_0.1.0::git+https://github.com/marrink-lab/vermouth-martinize.git
+ depends = python-pbr
+ depends = python-setuptools>=30.3.0
+ depends = python-numpy: docs generation
+ depends = python-networkx: pairwise distance calculation
+ optdepends = python-sphinx
+ optdepends = python-scipy
+ source = martinize-git::git+https://github.com/marrink-lab/vermouth-martinize.git
md5sums = SKIP
pkgname = martinize-git
diff --git a/PKGBUILD b/PKGBUILD
index 18c9fa14ab51..18ebb88232d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,38 @@
# Maintainer: Matthijs Tadema <M dot J dot Tadema at protonmail dot com>
+# Maintainer: Lorenzo Gaifas <brisvag at gmail dot com>
pkgname=martinize-git
-pkgver=0.1.0
+pkgver=v0.3.1.r8.2a50f80
pkgrel=1
pkgdesc="Describe and apply transformation on molecular structures and topologies"
arch=('any')
url="https://github.com/marrink-lab/vermouth-martinize"
license=('Apache')
-depends=('python>=3.5')
-makedepends=()
+depends=('python>=3.5' 'python-pbr' 'python-setuptools>=30.3.0' 'python-numpy'
+ 'python-networkx')
+makedepends=('git')
checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
+optdepends=('python-sphinx: docs generation'
+ 'python-scipy: pairwise distance calculation')
+provides=('martinize')
+conflicts=('martinize')
replaces=()
backup=()
options=()
install=
changelog=
-source=("${pkgname}_${pkgver}::git+https://github.com/marrink-lab/vermouth-martinize.git")
+source=("${pkgname}::git+https://github.com/marrink-lab/vermouth-martinize.git")
noextract=()
md5sums=('SKIP')
validpgpkeys=()
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+
package() {
- cd ${pkgname}_${pkgver}
+ cd ${srcdir}/${pkgname}
/usr/bin/env python3 setup.py install --prefix="$pkgdir/usr/"
}