summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-15 16:39:50 +0800
committerzxp198210052023-07-15 16:39:50 +0800
commit11bf826404076e56eafb5d4db0747f1341ef0d85 (patch)
tree679a7b183f5c9a32e65c84dee10c170197a50a84
downloadaur-11bf826404076e56eafb5d4db0747f1341ef0d85.tar.gz
first release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--marvin.sh8
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b830709931a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = marvin-bin
+ pkgdesc = Open Source record and playback test automation for the web.
+ pkgver = 0.4.9
+ pkgrel = 1
+ url = https://rolandbernard.github.io/marvin/
+ arch = x86_64
+ license = MIT
+ depends = bash
+ depends = electron24
+ provides = marvin
+ conflicts = marvin
+ options = !strip
+ source = marvin-0.4.9.AppImage::https://github.com/rolandbernard/marvin/releases/download/v0.4.9/Marvin-0.4.9.AppImage
+ source = LICENSE::https://raw.githubusercontent.com/rolandbernard/marvin/master/LICENSE
+ source = marvin.sh
+ sha256sums = 624a42d8d31d56bd9a3b82f4b6258ebffd9b5f5d623575b44b120f3646ae269e
+ sha256sums = 67cc90dae7113cf3572e7ae6b893b8e06960f696a6a1d3fc6b36b607cea970d6
+ sha256sums = 213e77f2af6e34b850b98efae7a87fd4fe87c5a2ab4ec7e133a4b0e6eeb6a321
+
+pkgname = marvin-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fda292161831
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="marvin-bin"
+pkgver=0.4.9
+pkgrel=1
+pkgdesc="Open Source record and playback test automation for the web."
+arch=('x86_64')
+url="https://rolandbernard.github.io/marvin/"
+_githuburl="https://github.com/rolandbernard/marvin"
+license=('MIT')
+conflicts=("${pkgname%-bin}")
+provides=("${pkgname%-bin}")
+depends=('bash' 'electron24')
+options=(!strip)
+_install_path="/opt/appimages"
+source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/Marvin-${pkgver}.AppImage"
+ "LICENSE::https://raw.githubusercontent.com/rolandbernard/marvin/master/LICENSE"
+ "${pkgname%-bin}.sh")
+sha256sums=('624a42d8d31d56bd9a3b82f4b6258ebffd9b5f5d623575b44b120f3646ae269e'
+ '67cc90dae7113cf3572e7ae6b893b8e06960f696a6a1d3fc6b36b607cea970d6'
+ '213e77f2af6e34b850b98efae7a87fd4fe87c5a2ab4ec7e133a4b0e6eeb6a321')
+prepare() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/marvin.sh b/marvin.sh
new file mode 100644
index 000000000000..67ad1cf6c637
--- /dev/null
+++ b/marvin.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron24
+_ASAR="/opt/marvin/marvin.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file