summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-15 15:20:24 +0800
committerzxp198210052023-11-15 15:20:24 +0800
commit542c80903891c700b67561cec3714658cdeb681d (patch)
tree1af6b2c43cb08b3663c510fa66115cc4bfc03b36
parent9dd19ec68ba0038921b1145818222d988214a601 (diff)
downloadaur-542c80903891c700b67561cec3714658cdeb681d.tar.gz
fix errors
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
-rw-r--r--marvin.sh5
3 files changed, 35 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e907d1310e6..798416aa31a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,18 @@
pkgbase = marvin-bin
pkgdesc = An app launcher for Linux and Windows
pkgver = 0.4.9
- pkgrel = 4
+ pkgrel = 5
url = https://rolandbernard.github.io/marvin/
arch = x86_64
license = MIT
- depends = bash
+ makedepends = squashfuse
depends = electron24
+ depends = libx11
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = libdbusmenu-glib
+ depends = gtk2
+ depends = dbus-glib
provides = marvin=0.4.9
conflicts = marvin
source = marvin-0.4.9.AppImage::https://github.com/rolandbernard/marvin/releases/download/v0.4.9/Marvin-0.4.9.AppImage
@@ -14,6 +20,6 @@ pkgbase = marvin-bin
source = marvin.sh
sha256sums = 624a42d8d31d56bd9a3b82f4b6258ebffd9b5f5d623575b44b120f3646ae269e
sha256sums = 67cc90dae7113cf3572e7ae6b893b8e06960f696a6a1d3fc6b36b607cea970d6
- sha256sums = 756ab370a11ec5b693fed4c7a927743a42aaeb8843f5ca36a5a91af486e15bf9
+ sha256sums = 7b706a3604995834c338d5898757a8353b16d76285a20c4c7fe6256eb6305fa2
pkgname = marvin-bin
diff --git a/PKGBUILD b/PKGBUILD
index de23313b1184..c4d6d4f56656 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,43 @@
pkgname=marvin-bin
_appname=Marvin
pkgver=0.4.9
-pkgrel=4
+pkgrel=5
pkgdesc="An app launcher for Linux and Windows"
arch=('x86_64')
url="https://rolandbernard.github.io/marvin/"
-_githuburl="https://github.com/rolandbernard/marvin"
+_ghurl="https://github.com/rolandbernard/marvin"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron24')
-source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
+depends=(
+ 'electron24'
+ 'libx11'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'libdbusmenu-glib'
+ 'gtk2'
+ 'dbus-glib'
+)
+makedepends=(
+ 'squashfuse'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
"LICENSE::https://raw.githubusercontent.com/rolandbernard/marvin/v${pkgver}/LICENSE"
- "${pkgname%-bin}.sh")
+ "${pkgname%-bin}.sh"
+)
sha256sums=('624a42d8d31d56bd9a3b82f4b6258ebffd9b5f5d623575b44b120f3646ae269e'
'67cc90dae7113cf3572e7ae6b893b8e06960f696a6a1d3fc6b36b607cea970d6'
- '756ab370a11ec5b693fed4c7a927743a42aaeb8843f5ca36a5a91af486e15bf9')
-prepare() {
+ '7b706a3604995834c338d5898757a8353b16d76285a20c4c7fe6256eb6305fa2')
+build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
diff --git a/marvin.sh b/marvin.sh
index 9eecc611a979..12f159b7a43d 100644
--- a/marvin.sh
+++ b/marvin.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron24
-_ASAR="/opt/marvin/app.asar"
+APPDIR=/usr/lib/marvin
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else