summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-16 10:04:10 +0800
committerzxp198210052023-08-16 10:04:10 +0800
commit73ca5d7f61561c5cff6d115a864eb447ba867972 (patch)
treed28b4c1f01215c6195f89e238508ada4d60c659c
parent11bf826404076e56eafb5d4db0747f1341ef0d85 (diff)
downloadaur-73ca5d7f61561c5cff6d115a864eb447ba867972.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b830709931a4..3436261621ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = marvin-bin
pkgdesc = Open Source record and playback test automation for the web.
pkgver = 0.4.9
- pkgrel = 1
+ pkgrel = 2
url = https://rolandbernard.github.io/marvin/
arch = x86_64
license = MIT
depends = bash
depends = electron24
- provides = marvin
+ provides = marvin=0.4.9
conflicts = marvin
- options = !strip
source = marvin-0.4.9.AppImage::https://github.com/rolandbernard/marvin/releases/download/v0.4.9/Marvin-0.4.9.AppImage
source = LICENSE::https://raw.githubusercontent.com/rolandbernard/marvin/master/LICENSE
source = marvin.sh
diff --git a/PKGBUILD b/PKGBUILD
index fda292161831..963105edcec1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname="marvin-bin"
+pkgname=marvin-bin
+_appname=Marvin
pkgver=0.4.9
-pkgrel=1
+pkgrel=2
pkgdesc="Open Source record and playback test automation for the web."
arch=('x86_64')
url="https://rolandbernard.github.io/marvin/"
_githuburl="https://github.com/rolandbernard/marvin"
license=('MIT')
+provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-provides=("${pkgname%-bin}")
depends=('bash' 'electron24')
-options=(!strip)
-_install_path="/opt/appimages"
-source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/Marvin-${pkgver}.AppImage"
+source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
"LICENSE::https://raw.githubusercontent.com/rolandbernard/marvin/master/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('624a42d8d31d56bd9a3b82f4b6258ebffd9b5f5d623575b44b120f3646ae269e'
@@ -26,7 +25,7 @@ package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
- install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file