summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-06 17:44:32 +0800
committerzxp198210052024-03-06 17:44:32 +0800
commit8dcfd68db18f42babe0f57d53a7044ff478690bf (patch)
tree4979816f84dca9bd7e4ac6fa3ad742e5925a8512
parent15a573ad21f1d6327b1dd72394618bd1be369f49 (diff)
downloadaur-8dcfd68db18f42babe0f57d53a7044ff478690bf.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
-rw-r--r--marvin.sh3
3 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84f06be94a54..b21043b6ebb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = marvin-bin
pkgdesc = An app launcher for Linux and Windows
pkgver = 0.4.9
- pkgrel = 7
+ pkgrel = 8
url = https://rolandbernard.github.io/marvin/
arch = x86_64
license = MIT
- makedepends = squashfuse
+ makedepends = fuse2
depends = electron24
- depends = dbus-glib
- depends = libdbusmenu-glib
- depends = gtk2
provides = marvin=0.4.9
conflicts = marvin
source = marvin-0.4.9.AppImage::https://github.com/rolandbernard/marvin/releases/download/v0.4.9/Marvin-0.4.9.AppImage
@@ -17,6 +14,6 @@ pkgbase = marvin-bin
source = marvin.sh
sha256sums = 624a42d8d31d56bd9a3b82f4b6258ebffd9b5f5d623575b44b120f3646ae269e
sha256sums = 67cc90dae7113cf3572e7ae6b893b8e06960f696a6a1d3fc6b36b607cea970d6
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = marvin-bin
diff --git a/PKGBUILD b/PKGBUILD
index 51fe14d831bc..e1c5eaf62f6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=marvin-bin
_appname=Marvin
pkgver=0.4.9
_electronversion=24
-pkgrel=7
+pkgrel=8
pkgdesc="An app launcher for Linux and Windows"
arch=('x86_64')
url="https://rolandbernard.github.io/marvin/"
@@ -13,12 +13,9 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'dbus-glib'
- 'libdbusmenu-glib'
- 'gtk2'
)
makedepends=(
- 'squashfuse'
+ 'fuse2'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
@@ -27,7 +24,7 @@ source=(
)
sha256sums=('624a42d8d31d56bd9a3b82f4b6258ebffd9b5f5d623575b44b120f3646ae269e'
'67cc90dae7113cf3572e7ae6b893b8e06960f696a6a1d3fc6b36b607cea970d6'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/marvin.sh b/marvin.sh
index f9ced1432cfc..86cb3dc6a9bf 100644
--- a/marvin.sh
+++ b/marvin.sh
@@ -1,10 +1,11 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then