summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoidujeu2020-04-16 12:14:54 +0530
committerRoidujeu2020-04-16 12:14:54 +0530
commit1c57a8b4fb642c3b5a05dccc2fe1d7f104cba990 (patch)
tree8efab2dcda37c449bdc33dde776ce807b4a80d0b
downloadaur-1c57a8b4fb642c3b5a05dccc2fe1d7f104cba990.tar.gz
first commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
-rw-r--r--marvin_dsc-1.0.0.tar.xzbin0 -> 8420 bytes
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c173a6c96ba4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = marvin_dsc
+ pkgdesc = A minimalist software which helps in setting up an android development environment.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Roidujeu/easy-android-sdk
+ arch = x86_64
+ license = MIT
+ makedepends = make>=3.0.0
+ depends = curl>=1.0.0
+ depends = unzip>=3.0.0
+ depends = tar>=1.0
+ depends = ncurses>=4.0.0
+ source = marvin_dsc-1.0.0.tar.xz
+
+pkgname = marvin_dsc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3bbe480ae7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Govind K <theamazingndnivog@outlook.com>
+
+pkgname=marvin_dsc
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="A minimalist software which helps in setting up an android development environment."
+arch=('x86_64')
+url="https://github.com/Roidujeu/easy-android-sdk"
+license=('MIT')
+groups=()
+depends=('curl>=1.0.0' 'unzip>=3.0.0' 'tar>=1.0' 'ncurses>=4.0.0')
+makedepends=('make>=3.0.0')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.xz")
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ sudo make install
+}
+
+uninstall() {
+ sudo rm -rf /usr/bin/marvin
+ sudo rm -rf /usr/share/marvin
+}
diff --git a/marvin_dsc-1.0.0.tar.xz b/marvin_dsc-1.0.0.tar.xz
new file mode 100644
index 000000000000..09776bd79d73
--- /dev/null
+++ b/marvin_dsc-1.0.0.tar.xz
Binary files differ