summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCampbell Barton2016-10-18 19:16:05 +1100
committerCampbell Barton2016-10-18 19:16:05 +1100
commitdb4fac3dc540711bcc79253a440ce48803ce3fe4 (patch)
treec344c159e66758c3c007831d840820c5ea0dd973
downloadaur-maryspeak-git.tar.gz
Initial version of maryspeak package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD48
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6fa90d7dcf3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = maryspeak-git
+ pkgdesc = Command line access to MaryTTS (text to speech) software.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/ideasman42/maryspeak
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = apache-ant
+ depends = marytts
+ source = git+https://github.com/ideasman42/maryspeak.git
+ md5sums = SKIP
+
+pkgname = maryspeak-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..447b1e1c4cbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Campbell Barton <ideasman42@gmail.com>
+
+_pkgname=maryspeak
+_version=git
+pkgver=1.0
+pkgname=${_pkgname}-${_version}
+pkgrel=1
+pkgdesc="Command line access to MaryTTS (text to speech) software."
+arch=('i686' 'x86_64')
+
+url="https://github.com/ideasman42/${_pkgname}"
+license=('GPL')
+groups=()
+depends=('marytts')
+makedepends=('apache-ant')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+${url}.git"
+)
+noextract=()
+md5sums=(
+'SKIP'
+) #autofill using updpkgsums
+
+build() {
+ cd $_pkgname
+
+ cat << EOF > maryspeak
+#!/bin/sh
+exec java -cp "/opt/marytts/lib/*" -Dmary.base=/opt/marytts maryspeak.Maryspeak "\$@"
+EOF
+ chmod +x maryspeak
+
+ ant
+}
+
+package() {
+ mkdir $pkgdir/opt/marytts/lib -p
+ mkdir $pkgdir/usr/bin -p
+ cp $_pkgname/maryspeak.jar $pkgdir/opt/marytts/lib/
+ cp $_pkgname/maryspeak $pkgdir/usr/bin/
+}