summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfenugrec2020-11-07 09:17:47 -0500
committerfenugrec2020-11-07 09:17:47 -0500
commit16c3cbe72ec690c934d09dda41d090f43ee068c7 (patch)
tree020e6e8542b607d080e27a25a00a10013d8aba27
parente918ee74231596468a4e8aacb4d8b7c2118b4a1f (diff)
downloadaur-16c3cbe72ec690c934d09dda41d090f43ee068c7.tar.gz
Update to 1.42-bld178
build only minimal docs so that texlive isn't required
-rw-r--r--.SRCINFO10
-rw-r--r--Makefile.def21
-rw-r--r--PKGBUILD23
-rw-r--r--makefile_nodocs.patch19
4 files changed, 56 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7ce9098cbee..48425e0cc969 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = mas
pkgdesc = Macro cross-assembler (asl) for various processors and microcontrollers.
- pkgver = 1.42b138
+ pkgver = 1.42b178
pkgrel = 1
url = http://john.ccac.rwth-aachen.de:8000/as/
arch = i686
arch = x86_64
license = GPL2
- source = http://john.ccac.rwth-aachen.de:8000/ftp/as/source/c_version/asl-current-142-bld138.tar.bz2
+ source = http://john.ccac.rwth-aachen.de:8000/ftp/as/source/c_version/asl-current-142-bld178.tar.bz2
source = Makefile.def
- sha256sums = 903510cff70ba134a357b00e3e00f69473ebd53ade903ec91fb5d3fc61facf32
- sha256sums = 5368cc58e2c4bb5009ded7ce4db1b740a5ebf82943cd44426290e29e165d7db4
+ source = makefile_nodocs.patch
+ sha256sums = cb3740a96be117719b1a4b8de2bc02a84146898ee774de5cf3e0b352275209b2
+ sha256sums = 0507795f2558bff086bc3d88169529a6dba5fe6cf4731433eb1388b421fa6d9f
+ sha256sums = 67c5d45388250f030c0cf5dfa4c18bec0f55aa2d5ae9b21875d32b0167d3e9d7
pkgname = mas
diff --git a/Makefile.def b/Makefile.def
index 00568869aff7..45df6d2c4413 100644
--- a/Makefile.def
+++ b/Makefile.def
@@ -3,15 +3,24 @@
# - remove "-fomit-frame-pointer" which is enabled at -O3 anyway
# - prepend "$DESTDIR" so "make install" will work as desired
-CC = gcc
-LD = gcc
override CFLAGS += -O3 -Wall
-TARG_OBJEXTENSION = .o
-TARG_EXEXTENSION =
+OBJDIR =
+CC = gcc
+HOST_OBJEXTENSION = .o
+LD = $(CC)
+LDFLAGS =
+HOST_EXEXTENSION =
+
+# ...for the actual build targets. This is the simple case for no cross-build:
-HOST_OBJEXTENSION = $(TARG_OBJEXTENSION)
-HOST_EXEXTENSION = $(TARG_EXEXTENSION)
+TARG_OBJDIR = $(OBJDIR)
+TARG_CC = $(CC)
+TARG_CFLAGS = $(CFLAGS)
+TARG_OBJEXTENSION = $(HOST_OBJEXTENSION)
+TARG_LD = $(LD)
+TARG_LDFLAGS = $(LDFLAGS)
+TARG_EXEXTENSION = $(HOST_EXEXTENSION)
# -------------------------------------------------------------------------
# directories where binaries, includes, and manpages should go during
diff --git a/PKGBUILD b/PKGBUILD
index 4fce13adb607..47248918bbb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,36 @@
# contributed by fenugrec 2018/11
-# TODO : optdepends for building docs ?
+# note : this only compiles the minimum amount of docs.
# The author calls this 'AS' but names his Debian package 'asl'.
# Unfortunately there's an old, unrelated 'asl' package in AUR,
# and 'as' would clash with "GNU AS", therefore this is 'mas'.
+#
pkgname=mas
-pkgver=1.42b138
+pkgver=1.42b178
_pkgfilebase=asl-current
-_pkgfile=${_pkgfilebase}-142-bld138
+_pkgfile=${_pkgfilebase}-142-bld178
pkgrel=1
-
pkgdesc="Macro cross-assembler (asl) for various processors and microcontrollers."
arch=("i686" "x86_64")
url='http://john.ccac.rwth-aachen.de:8000/as/'
license=('GPL2')
+#required for full docs
+#makedepends=('texlive-core')
+
source=("http://john.ccac.rwth-aachen.de:8000/ftp/as/source/c_version/${_pkgfile}.tar.bz2"
- "Makefile.def")
+ "Makefile.def"
+ "makefile_nodocs.patch")
-sha256sums=('903510cff70ba134a357b00e3e00f69473ebd53ade903ec91fb5d3fc61facf32'
- '5368cc58e2c4bb5009ded7ce4db1b740a5ebf82943cd44426290e29e165d7db4')
+sha256sums=('cb3740a96be117719b1a4b8de2bc02a84146898ee774de5cf3e0b352275209b2'
+ '0507795f2558bff086bc3d88169529a6dba5fe6cf4731433eb1388b421fa6d9f'
+ '67c5d45388250f030c0cf5dfa4c18bec0f55aa2d5ae9b21875d32b0167d3e9d7')
prepare() {
cd "${_pkgfilebase}"
cp ../Makefile.def .
+ patch -i ../makefile_nodocs.patch
}
build() {
@@ -37,3 +43,6 @@ package() {
cd "${_pkgfilebase}"
make DESTDIR="$pkgdir" install
}
+sha256sums=('cb3740a96be117719b1a4b8de2bc02a84146898ee774de5cf3e0b352275209b2'
+ '0507795f2558bff086bc3d88169529a6dba5fe6cf4731433eb1388b421fa6d9f'
+ '67c5d45388250f030c0cf5dfa4c18bec0f55aa2d5ae9b21875d32b0167d3e9d7')
diff --git a/makefile_nodocs.patch b/makefile_nodocs.patch
new file mode 100644
index 000000000000..3327175ac734
--- /dev/null
+++ b/makefile_nodocs.patch
@@ -0,0 +1,19 @@
+*** Makefile.orig 2020-11-07 09:07:15.892839678 -0500
+--- Makefile 2020-11-07 09:10:03.862839900 -0500
+***************
+*** 22,28 ****
+
+ include makedefs.src
+
+! docs: docs_DE docs_EN
+
+ $(ASLTARGET): $(ASM_OBJECTS) $(AS_OBJECTS) $(ST_OBJECTS) $(CODE_OBJECTS) $(NLS_OBJECTS)
+ $(TARG_LD) -o $(ASLTARGET) $(ASM_OBJECTS) $(AS_OBJECTS) $(ST_OBJECTS) $(CODE_OBJECTS) $(NLS_OBJECTS) -lm $(TARG_LDFLAGS)
+--- 22,28 ----
+
+ include makedefs.src
+
+! docs: docs_DE_notex docs_EN_notex
+
+ $(ASLTARGET): $(ASM_OBJECTS) $(AS_OBJECTS) $(ST_OBJECTS) $(CODE_OBJECTS) $(NLS_OBJECTS)
+ $(TARG_LD) -o $(ASLTARGET) $(ASM_OBJECTS) $(AS_OBJECTS) $(ST_OBJECTS) $(CODE_OBJECTS) $(NLS_OBJECTS) -lm $(TARG_LDFLAGS)