summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Rease2022-03-17 11:07:58 -0700
committerMatthew Rease2022-03-17 11:07:58 -0700
commit15dfbc048af817df34caaa71ba6d08bf4a88480f (patch)
treee2860513a5000780ceb42b8b31b28c75f8dc8d19
downloadaur-15dfbc048af817df34caaa71ba6d08bf4a88480f.tar.gz
Initial AUR version.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96122a05f02b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = mash-sh
+ pkgdesc = A bash/zsh like shell, written in C.
+ pkgver = 0.0
+ pkgrel = 1
+ url = https://gitlab.com/Magicrafter13/mash
+ arch = x86_64
+ arch = aarch64
+ arch = ppc
+ license = GPL3
+ source = mash-sh::git+https://gitlab.com/Magicrafter13/mash.git
+ sha256sums = SKIP
+
+pkgname = mash-sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbe3aeab0788
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Matthew Rease <scubaventure101[AT]hotmail[DOT]com>
+pkgname=mash-sh
+pkgver=0.0
+pkgrel=1
+pkgdesc="A bash/zsh like shell, written in C."
+arch=('x86_64' 'aarch64' 'ppc')
+url="https://gitlab.com/Magicrafter13/mash"
+license=('GPL3')
+changelog=
+source=("$pkgname"::"git+https://gitlab.com/Magicrafter13/mash.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+
+ make -j
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir/usr/bin" install
+}