summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Rease2022-03-31 19:49:15 -0700
committerMatthew Rease2022-03-31 19:49:15 -0700
commit35664ff3e2e1fa7118f592e1e0b4942293210902 (patch)
treea39ab8a94e11935ed039c1053d5148351de71d34
parent15dfbc048af817df34caaa71ba6d08bf4a88480f (diff)
downloadaur-35664ff3e2e1fa7118f592e1e0b4942293210902.tar.gz
Switch from VCS.
I do still want a VCS build, so I'll probably make a mash-git package now... But for some reason when I made this I didn't even think about the fact that I wasn't even cloning a specific commit.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96122a05f02b..8a315091c2d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = mash-sh
pkgdesc = A bash/zsh like shell, written in C.
pkgver = 0.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/Magicrafter13/mash
arch = x86_64
arch = aarch64
arch = ppc
license = GPL3
- source = mash-sh::git+https://gitlab.com/Magicrafter13/mash.git
- sha256sums = SKIP
+ source = https://gitlab.com/Magicrafter13/mash/-/archive/alpha-aur-1/mash-alpha-aur-1.tar.gz
+ sha256sums = 11824bcad25c7e3662b4c198179b02de2247dc0c897bb407eb00443aefc65366
pkgname = mash-sh
diff --git a/PKGBUILD b/PKGBUILD
index dbe3aeab0788..322fb94fbcb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Matthew Rease <scubaventure101[AT]hotmail[DOT]com>
pkgname=mash-sh
pkgver=0.0
-pkgrel=1
+_pkgver='alpha-aur-1' # temporary - when mash begins using semantic versioning this will be removed
+pkgrel=2
pkgdesc="A bash/zsh like shell, written in C."
arch=('x86_64' 'aarch64' 'ppc')
url="https://gitlab.com/Magicrafter13/mash"
license=('GPL3')
changelog=
-source=("$pkgname"::"git+https://gitlab.com/Magicrafter13/mash.git")
-sha256sums=('SKIP')
+source=("https://gitlab.com/Magicrafter13/mash/-/archive/${_pkgver}/mash-${_pkgver}.tar.gz")
+sha256sums=('11824bcad25c7e3662b4c198179b02de2247dc0c897bb407eb00443aefc65366')
build() {
- cd "$pkgname"
+ cd "mash-$_pkgver"
make -j
}
package() {
- cd "$pkgname"
+ cd "mash-$_pkgver"
- make DESTDIR="$pkgdir/usr/bin" install
+ mkdir -p "$pkgdir/usr/bin"
+ cp mash "$pkgdir/usr/bin/mash"
}