summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-20 13:52:05 +0800
committerzxp198210052024-02-20 13:52:05 +0800
commit35fe2ad52a3ec60b988f6d57f04b5dd92401feab (patch)
tree58030e4f5a8884aab2b406c8f8ce250ccfd7ea74
parent62d5b201b0964ea1e6564c462c36ebb5a3037395 (diff)
downloadaur-35fe2ad52a3ec60b988f6d57f04b5dd92401feab.tar.gz
update to 3.11.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD11
-rw-r--r--masscode.sh9
3 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 919cac72cc62..0839583958b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = masscode-bin
pkgdesc = A free and open source code snippets manager for developers
- pkgver = 3.10.0
- pkgrel = 3
+ pkgver = 3.11.0
+ pkgrel = 1
url = https://masscode.io/
arch = x86_64
- license = AGPL3
+ license = AGPL-3.0-only
makedepends = gendesk
- makedepends = squashfs-tools
depends = electron16
- provides = masscode=3.10.0
+ provides = masscode=3.11.0
conflicts = masscode
- source = masscode-3.10.0.snap::https://github.com/massCodeIO/massCode/releases/download/v3.10.0/masscode_3.10.0_amd64.snap
+ source = masscode-3.11.0.snap::https://github.com/massCodeIO/massCode/releases/download/v3.11.0/masscode_3.11.0_amd64.snap
source = masscode.sh
- sha256sums = d4e9aebeabac38aba5180a89083c25ea2e53028ce39a44d57a058d8d76232d6d
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 72df12e9b5a5a7afef0d31c75f5c56994bbbe3bd8c2c87b5dee9baa919a9591f
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = masscode-bin
diff --git a/PKGBUILD b/PKGBUILD
index 129c9cf55e9c..b9a605ef9ab5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Anton Reshetov
pkgname=masscode-bin
_pkgname=massCode
-pkgver=3.10.0
+pkgver=3.11.0
_electronversion=16
-pkgrel=3
+pkgrel=1
pkgdesc="A free and open source code snippets manager for developers"
arch=('x86_64')
url="https://masscode.io/"
_ghurl="https://github.com/massCodeIO/massCode"
-license=('AGPL3')
+license=('AGPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -16,14 +16,13 @@ depends=(
)
makedepends=(
'gendesk'
- 'squashfs-tools'
)
source=(
"${pkgname%-bin}-${pkgver}.snap::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.snap"
"${pkgname%-bin}.sh"
)
-sha256sums=('d4e9aebeabac38aba5180a89083c25ea2e53028ce39a44d57a058d8d76232d6d'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+sha256sums=('72df12e9b5a5a7afef0d31c75f5c56994bbbe3bd8c2c87b5dee9baa919a9591f'
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/masscode.sh b/masscode.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/masscode.sh
+++ b/masscode.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file