summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-22 15:08:35 +0800
committerzxp198210052024-03-22 15:08:35 +0800
commit9876c4f8213488ba877be5e3cd24eb51c3ac096c (patch)
tree68a65e392b8be1d6b40fb3ee67c55a8a8f300957
parentaef72212758db0243a621eb2ad0bf1d27cde4dea (diff)
downloadaur-9876c4f8213488ba877be5e3cd24eb51c3ac096c.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--masscode.sh5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb957236049c..712f68dde355 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = masscode-bin
pkgdesc = A free and open source code snippets manager for developers
pkgver = 3.11.0
- pkgrel = 2
+ pkgrel = 3
url = https://masscode.io/
arch = x86_64
license = AGPL-3.0-only
@@ -13,6 +13,6 @@ pkgbase = masscode-bin
source = masscode-3.11.0.snap::https://github.com/massCodeIO/massCode/releases/download/v3.11.0/masscode_3.11.0_amd64.snap
source = masscode.sh
sha256sums = 72df12e9b5a5a7afef0d31c75f5c56994bbbe3bd8c2c87b5dee9baa919a9591f
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = masscode-bin
diff --git a/PKGBUILD b/PKGBUILD
index f3d00053ad19..891175017266 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=masscode-bin
_pkgname=massCode
pkgver=3.11.0
_electronversion=16
-pkgrel=2
+pkgrel=3
pkgdesc="A free and open source code snippets manager for developers"
arch=('x86_64')
url="https://masscode.io/"
@@ -23,11 +23,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('72df12e9b5a5a7afef0d31c75f5c56994bbbe3bd8c2c87b5dee9baa919a9591f'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
unsquashfs "${srcdir}/${pkgname%-bin}-${pkgver}.snap"
gendesk -q -f -n --categories="Development" --name="${_pkgname}" --exec="${pkgname%-bin} %U"
diff --git a/masscode.sh b/masscode.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/masscode.sh
+++ b/masscode.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file