summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-08 17:54:31 +0800
committerzxp198210052024-03-08 17:54:31 +0800
commitaef72212758db0243a621eb2ad0bf1d27cde4dea (patch)
treeb819b9ea7bcbf43fa492fbc712160a44e9ce84fb
parent35fe2ad52a3ec60b988f6d57f04b5dd92401feab (diff)
downloadaur-aef72212758db0243a621eb2ad0bf1d27cde4dea.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--masscode.sh3
3 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0839583958b2..bb957236049c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = masscode-bin
pkgdesc = A free and open source code snippets manager for developers
pkgver = 3.11.0
- pkgrel = 1
+ pkgrel = 2
url = https://masscode.io/
arch = x86_64
license = AGPL-3.0-only
makedepends = gendesk
- depends = electron16
+ makedepends = squashfs-tools
+ depends = electron16-bin
provides = masscode=3.11.0
conflicts = masscode
source = masscode-3.11.0.snap::https://github.com/massCodeIO/massCode/releases/download/v3.11.0/masscode_3.11.0_amd64.snap
source = masscode.sh
sha256sums = 72df12e9b5a5a7afef0d31c75f5c56994bbbe3bd8c2c87b5dee9baa919a9591f
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = masscode-bin
diff --git a/PKGBUILD b/PKGBUILD
index b9a605ef9ab5..f3d00053ad19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=masscode-bin
_pkgname=massCode
pkgver=3.11.0
_electronversion=16
-pkgrel=1
+pkgrel=2
pkgdesc="A free and open source code snippets manager for developers"
arch=('x86_64')
url="https://masscode.io/"
@@ -12,24 +12,25 @@ license=('AGPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
)
makedepends=(
'gendesk'
+ 'squashfs-tools'
)
source=(
"${pkgname%-bin}-${pkgver}.snap::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.snap"
"${pkgname%-bin}.sh"
)
sha256sums=('72df12e9b5a5a7afef0d31c75f5c56994bbbe3bd8c2c87b5dee9baa919a9591f'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
unsquashfs "${srcdir}/${pkgname%-bin}-${pkgver}.snap"
- gendesk -q -f -n --categories "Development" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
+ gendesk -q -f -n --categories="Development" --name="${_pkgname}" --exec="${pkgname%-bin} %U"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/masscode.sh b/masscode.sh
index f9ced1432cfc..86cb3dc6a9bf 100644
--- a/masscode.sh
+++ b/masscode.sh
@@ -1,10 +1,11 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then