summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArkaprabha Chakraborty2024-02-02 01:03:23 +0530
committerArkaprabha Chakraborty2024-02-02 01:06:25 +0530
commitcd4bcad8dc44ab94ef0597bef2c94fbb85aaab11 (patch)
tree08fe50f08b98c257cc6c81b8e644c53c66d2b54f
parent0d0a91e9e6db6e735b45a482a763b53cc2e1234a (diff)
downloadaur-massren.tar.gz
chore: add 'glibc' to 'depends' in PKGBUILD
- Include 'glibc' in the 'depends' array to explicitly specify the runtime dependency.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD47
2 files changed, 26 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e57fb161ab9..3847cd5a7d23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,8 +5,9 @@ pkgbase = massren
url = https://github.com/laurent22/massren
arch = x86_64
license = MIT
- conflicts = massren-git
makedepends = go
+ depends = glibc
+ conflicts = massren
source = massren-1.5.6.tar.gz::https://github.com/laurent22/massren/archive/refs/tags/v1.5.6.tar.gz
sha256sums = 49758b477a205f3fbf5bbe72c2575fff8b5536f8c6b45f8f6bd2fdde023ce874
diff --git a/PKGBUILD b/PKGBUILD
index 9099fffa4d65..3f775ec085fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,40 @@
-# Maintainer: arkorty <arkorty@gmail.com>
+# Maintainer: Arkaprabha Chakraborty <arkorty@gmail.com>
# Contributor: siers <wimuan@gmail.com>
-pkgname=massren
-pkgver=1.5.6
-pkgrel=1
-pkgdesc="Easily rename multiple files using your text editor"
-url="https://github.com/laurent22/massren"
-license=("MIT")
+pkgname='massren'
+pkgver='1.5.6'
+pkgrel='1'
+pkgdesc='Easily rename multiple files using your text editor'
+url='https://github.com/laurent22/massren'
+license=('MIT')
arch=('x86_64')
-conflicts=("massren-git")
+conflicts=('massren')
+depends=('glibc')
makedepends=('go')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('49758b477a205f3fbf5bbe72c2575fff8b5536f8c6b45f8f6bd2fdde023ce874')
prepare() {
- cd "$pkgname-$pkgver"
- mkdir -p build/
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
- go mod init "${url#https://}"
- go mod tidy
+ go mod init "${url#https://}"
+ go mod tidy
}
build() {
- cd "$pkgname-$pkgver"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -o build .
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build .
}
package() {
- cd "$pkgname-$pkgver"
- sed -n '/## License/,$p' README.md > LICENSE
- install -Dm755 "build/$pkgname" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+ cd "$pkgname-$pkgver"
+ sed -n '/## License/,$p' README.md > LICENSE
+ install -Dm755 "build/$pkgname" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}