summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Nguyen2017-08-26 02:21:05 +0700
committerTom Nguyen2017-08-26 02:21:05 +0700
commit0c3e3879d71689d943d50bdba1530758f072ea36 (patch)
tree91b57c05840d21e559051eb7865b12f428a6fd2a
parent5d4ef0b352fec0244b2bd00a7b722424e0a7b757 (diff)
downloadaur-0c3e3879d71689d943d50bdba1530758f072ea36.tar.gz
Force package to fixed commit and fixed formatting
- reflected describe format in cli-c/build to pkgver - replaced link from #branch=master to fixed #commit=b1985a2b - retabbed
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD34
3 files changed, 24 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4c264f0c85b..70cdbef7ebb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 8 02:06:53 UTC 2017
+# Fri Aug 25 19:18:53 UTC 2017
pkgbase = masterpassword-cli-git
pkgdesc = CLI version of Master Password. (git-version)
- pkgver = 20170808.r1222.ee50a4d0
+ pkgver = 2.5.cli.2.r62.gb1985a2b
pkgrel = 1
url = https://github.com/Lyndir/MasterPassword
arch = any
@@ -14,7 +14,7 @@ pkgbase = masterpassword-cli-git
optdepends = xclip: copy password to clipboard
conflicts = masterpassword-cli
conflicts = masterpassword-cli-git
- source = masterpassword-cli::git+https://github.com/Lyndir/MasterPassword.git#branch=master
+ source = masterpassword-cli::git+https://github.com/Lyndir/MasterPassword.git#commit=b1985a2b
sha256sums = SKIP
pkgname = masterpassword-cli-git
diff --git a/.gitignore b/.gitignore
index 05146be11614..f71c635dafda 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,4 @@
-*~
-*/pkg/*
-*/src/*
-*/*.tar.*
-*/*.zip
-*/*/
-*/*/*
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index d6bb62092a5d..0ba2746b3d55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Patrick Wozniak <email@patwoz.de>
pkgname=masterpassword-cli-git
-pkgver=20170808.r1222.ee50a4d0
+pkgver=2.5.cli.2.r62.gb1985a2b
pkgrel=1
pkgdesc="CLI version of Master Password. (git-version)"
@@ -11,36 +11,36 @@ url="https://github.com/Lyndir/MasterPassword"
license=('GPL3')
optdepends=(
- 'xclip: copy password to clipboard'
+ 'xclip: copy password to clipboard'
)
makedepends=(
- 'gcc'
- 'git'
- 'libsodium'
- 'openssl'
+ 'gcc'
+ 'git'
+ 'libsodium'
+ 'openssl'
)
conflicts=(
- 'masterpassword-cli'
- 'masterpassword-cli-git'
+ 'masterpassword-cli'
+ 'masterpassword-cli-git'
)
-source=("${pkgname%-git}::git+https://github.com/Lyndir/MasterPassword.git#branch=master")
+source=("${pkgname%-git}::git+https://github.com/Lyndir/MasterPassword.git#commit=b1985a2b")
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
- printf "%s.r%s.%s" "$(date +%Y%m%d)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${pkgname%-git}"
+ echo $(git describe --match '*-cli*' --long --dirty --broken) | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g;s/\.rc/rc/;s/ //g'
}
build() {
- cd "${pkgname%-git}/platform-independent/cli-c"
- targets="mpw" ./build
+ cd "${pkgname%-git}/platform-independent/cli-c"
+ targets="mpw" ./build
}
package() {
- cd "${pkgname%-git}"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+ cd "${pkgname%-git}"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
- cd "platform-independent/cli-c"
- /usr/bin/install -Dm755 "mpw" "$pkgdir/usr/bin/mpw"
+ cd "platform-independent/cli-c"
+ /usr/bin/install -Dm755 "mpw" "$pkgdir/usr/bin/mpw"
}