summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2023-07-08 15:42:23 +0000
committerAnthony Wang2023-07-08 15:42:43 +0000
commit1ea041564ce7098fd2cc5520ff947d0263b7b683 (patch)
tree197e8c8769f55fd2645dc09ae62d5572322aa7c0
parentf35b3575acff2e3f2991a2df77fb0d6829b2aac1 (diff)
downloadaur-1ea041564ce7098fd2cc5520ff947d0263b7b683.tar.gz
Append gem 'erb' to Gemfile as suggested by peippo
-rw-r--r--PKGBUILD1
-rw-r--r--mastodon.install2
2 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fea87e0292ce..0b79688800e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,6 +42,7 @@ prepare() {
cd mastodon-$pkgver
echo "gem 'psych', '< 4'" >> Gemfile
+ echo "gem 'erb'" >> Gemfile
}
build() {
diff --git a/mastodon.install b/mastodon.install
index 99aae622c954..c6dc93fad4a5 100644
--- a/mastodon.install
+++ b/mastodon.install
@@ -16,8 +16,6 @@ post_upgrade() {
echo "Setting ownership of mastodon files"
find -path ./public/system -prune -o -exec chown -h mastodon:mastodon {} +
- echo "Refreshing bundle"
- sudo -u mastodon RAILS_ENV=production NODE_OPTIONS=--openssl-legacy-provider bundle install --redownload --standalone
echo "Upgrading database schema"
sudo -u mastodon RAILS_ENV=production bundle exec rails db:migrate
echo "Precompiling assets"