summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorliolok2020-05-13 10:23:11 +0800
committerliolok2020-05-13 10:23:11 +0800
commit2bcccfe1c9221b91912e466349c670ba59c3fd46 (patch)
tree217d39aa517b10407adccd0f67083982fdf8bf41
parenta939444ab732957b054a6dbebc75e68e494d3546 (diff)
downloadaur-2bcccfe1c9221b91912e466349c670ba59c3fd46.tar.gz
upgrade to v3.1.3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e0147989d6b..7cda6ee5889e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mastodon
pkgdesc = Self-hosted social media and network server based on ActivityPub and OStatus
- pkgver = 3.1.2
- pkgrel = 2
+ pkgver = 3.1.3
+ pkgrel = 1
url = https://github.com/tootsuite/mastodon
install = mastodon.install
arch = x86_64
@@ -14,8 +14,7 @@ pkgbase = mastodon
depends = libxml2
depends = libxslt
depends = libyaml
- depends = 'nodejs<=12.16.1'
- depends = 'nodejs>=10.19.0'
+ depends = nodejs
depends = postgresql
depends = redis
depends = ruby-bundler
@@ -23,11 +22,11 @@ pkgbase = mastodon
depends = yarn
depends = zlib
backup = etc/mastodon.conf
- source = https://github.com/tootsuite/mastodon/archive/v3.1.2.tar.gz
+ source = https://github.com/tootsuite/mastodon/archive/v3.1.3.tar.gz
source = mastodon.target
source = mastodon.sysusers.d
source = mastodon.tmpfiles.d
- sha512sums = 9c5e12fb0d46024d41f03f976a21cacf938285db93f1311a5bc2db1d703bc2ed675b39403fd87878a0632338c49bf88395c77d6809ad91b94bc6533f7d89e324
+ sha512sums = 2635fcc62d600f5115794113267fce3fb41db0cf321fbd92c92b1acc09805212c7993ba828e686be2e5bbeec9cc71adf4a7a6409678cce0fd0a89eb00633831c
sha512sums = c9820c2a83d08bd5d842a78e924682db97ebd5c7291b682603ad30dafcdcc5816c13e717ad39554f042b9d9ed71ab902ce3f604952264a900a72612ee8060acb
sha512sums = 4ee4210bde391e6dc782cb7c14f2cb968c95ad541aa0efcf843a811f8cc5f0d1067ee3c8346bb412aa9fd1dd5a8bd05a4524df7dc4a106957009853dd237074a
sha512sums = 73493680845e690d0cfd769fbbe68978c0a615602375078aea945ca1f1011404eb4b64972aec7a6e5efa720fb425d91b3f30025391c38ccf77e070ccb391e710
diff --git a/PKGBUILD b/PKGBUILD
index 7cc5d5cb6d98..f07b95e65d60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Fredrick Brennan <copypaste@kittens.ph>
pkgname=mastodon
-pkgver=3.1.2
-pkgrel=2
+pkgver=3.1.3
+pkgrel=1
pkgdesc='Self-hosted social media and network server based on ActivityPub and OStatus'
arch=(x86_64)
url=https://github.com/tootsuite/mastodon
@@ -16,8 +16,7 @@ depends=(ffmpeg
libxml2
libxslt
libyaml
- 'nodejs<=12.16.1'
- 'nodejs>=10.19.0'
+ nodejs
postgresql
redis
ruby-bundler
@@ -31,7 +30,7 @@ source=(https://github.com/tootsuite/mastodon/archive/v$pkgver.tar.gz
mastodon.target
mastodon.sysusers.d
mastodon.tmpfiles.d)
-sha512sums=('9c5e12fb0d46024d41f03f976a21cacf938285db93f1311a5bc2db1d703bc2ed675b39403fd87878a0632338c49bf88395c77d6809ad91b94bc6533f7d89e324'
+sha512sums=('2635fcc62d600f5115794113267fce3fb41db0cf321fbd92c92b1acc09805212c7993ba828e686be2e5bbeec9cc71adf4a7a6409678cce0fd0a89eb00633831c'
'c9820c2a83d08bd5d842a78e924682db97ebd5c7291b682603ad30dafcdcc5816c13e717ad39554f042b9d9ed71ab902ce3f604952264a900a72612ee8060acb'
'4ee4210bde391e6dc782cb7c14f2cb968c95ad541aa0efcf843a811f8cc5f0d1067ee3c8346bb412aa9fd1dd5a8bd05a4524df7dc4a106957009853dd237074a'
'73493680845e690d0cfd769fbbe68978c0a615602375078aea945ca1f1011404eb4b64972aec7a6e5efa720fb425d91b3f30025391c38ccf77e070ccb391e710')
@@ -44,17 +43,13 @@ prepare() {
# Allow use of higher Node minor versions
sed -i 's/"node": "/&^/' package.json
-
- # Fix `sidekiq-unique-jobs` 6.0.18 has been yanked
- sed -i 's/6\.0\.18/6\.0\.21/' Gemfile.lock
}
build() {
cd mastodon-$pkgver
bundle config set deployment 'true'
bundle config set without 'development test'
- bundle install \
- -j$(getconf _NPROCESSORS_ONLN)
+ bundle install -j$(getconf _NPROCESSORS_ONLN)
yarn install --pure-lockfile
}