summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2023-07-09 16:54:42 +0000
committerAnthony Wang2023-07-09 16:54:42 +0000
commit30471c17bd276f0af2a2bd4479387133b06a224a (patch)
treed3ebda95728f2ff0b2c2d4c754c44d2ecc97595d
parent1ea041564ce7098fd2cc5520ff947d0263b7b683 (diff)
downloadaur-30471c17bd276f0af2a2bd4479387133b06a224a.tar.gz
Add gcc git make sudo to depends
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a32fbfe38fbf..fc69b140b594 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,19 +6,22 @@ pkgbase = mastodon
install = mastodon.install
arch = any
license = AGPL3
- makedepends = git
depends = ffmpeg
+ depends = gcc
+ depends = git
depends = imagemagick
depends = libidn
depends = libpqxx
depends = libxml2
depends = libxslt
depends = libyaml
+ depends = make
depends = nodejs
depends = postgresql
+ depends = protobuf
depends = redis
depends = ruby-bundler
- depends = protobuf
+ depends = sudo
depends = yarn
depends = zlib
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 0b79688800e9..fc8ef9d71257 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,20 +12,23 @@ arch=(any)
url=https://github.com/mastodon/mastodon
license=(AGPL3)
depends=(ffmpeg
+ gcc
+ git
imagemagick
libidn
libpqxx
libxml2
libxslt
libyaml
+ make
nodejs
postgresql
+ protobuf
redis
ruby-bundler
- protobuf
+ sudo
yarn
zlib)
-makedepends=(git)
backup=(etc/mastodon.conf)
install=mastodon.install
options=(!strip)