summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2022-05-03 19:10:48 -0500
committerAnthony Wang2022-05-03 19:10:48 -0500
commit4da1ac01353c0ba6ef171babf7a26f5fa45de4ce (patch)
tree218cd22c9df15f3b5112f6515225a1b29c3f52d3
parentc51dac582d2142c8893206ef3516a63d96f7ca9b (diff)
downloadaur-4da1ac01353c0ba6ef171babf7a26f5fa45de4ce.tar.gz
Update to 3.5.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--mastodon.install19
3 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d867b31ea56..3f2152922dd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mastodon
pkgdesc = Your self-hosted, globally interconnected microblogging community
- pkgver = 3.5.1
+ pkgver = 3.5.2
pkgrel = 1
url = https://github.com/mastodon/mastodon
install = mastodon.install
@@ -23,11 +23,11 @@ pkgbase = mastodon
depends = zlib
options = !strip
backup = etc/mastodon.conf
- source = https://github.com/mastodon/mastodon/archive/v3.5.1.tar.gz
+ source = https://github.com/mastodon/mastodon/archive/v3.5.2.tar.gz
source = mastodon.target
source = mastodon.sysusers.d
source = mastodon.tmpfiles.d
- sha512sums = 1fb6f2f17384f217e5a04f140ca35db33449f68cc780af24a2f6f7611874849b9a6fa86a8a930b2da457e4f40c36505761705d140ccb1a56b17ed287d659ae53
+ sha512sums = de9def1681f394872bf5959d8dab2f0434f519183028924664177e61cd361aea6d48d265d06c63f40624be16506102e30b510fbc720c4708286528d946e5e9d4
sha512sums = c9820c2a83d08bd5d842a78e924682db97ebd5c7291b682603ad30dafcdcc5816c13e717ad39554f042b9d9ed71ab902ce3f604952264a900a72612ee8060acb
sha512sums = 4ee4210bde391e6dc782cb7c14f2cb968c95ad541aa0efcf843a811f8cc5f0d1067ee3c8346bb412aa9fd1dd5a8bd05a4524df7dc4a106957009853dd237074a
sha512sums = 27c4eb01d462c525b59e5808a3b2501b63a34425752128388fbde82f7eb5944b20d2f8d8b1be8ed8adb165cab4cfb8e13f90215f20989ca671a0422ffa37001f
diff --git a/PKGBUILD b/PKGBUILD
index 347b1564c1e2..49e7349429ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Fredrick Brennan <copypaste@kittens.ph>
pkgname=mastodon
-pkgver=3.5.1
+pkgver=3.5.2
pkgrel=1
pkgdesc='Your self-hosted, globally interconnected microblogging community'
arch=(x86_64)
@@ -33,7 +33,7 @@ source=(https://github.com/mastodon/mastodon/archive/v$pkgver.tar.gz
mastodon.target
mastodon.sysusers.d
mastodon.tmpfiles.d)
-sha512sums=('1fb6f2f17384f217e5a04f140ca35db33449f68cc780af24a2f6f7611874849b9a6fa86a8a930b2da457e4f40c36505761705d140ccb1a56b17ed287d659ae53'
+sha512sums=('de9def1681f394872bf5959d8dab2f0434f519183028924664177e61cd361aea6d48d265d06c63f40624be16506102e30b510fbc720c4708286528d946e5e9d4'
'c9820c2a83d08bd5d842a78e924682db97ebd5c7291b682603ad30dafcdcc5816c13e717ad39554f042b9d9ed71ab902ce3f604952264a900a72612ee8060acb'
'4ee4210bde391e6dc782cb7c14f2cb968c95ad541aa0efcf843a811f8cc5f0d1067ee3c8346bb412aa9fd1dd5a8bd05a4524df7dc4a106957009853dd237074a'
'27c4eb01d462c525b59e5808a3b2501b63a34425752128388fbde82f7eb5944b20d2f8d8b1be8ed8adb165cab4cfb8e13f90215f20989ca671a0422ffa37001f')
diff --git a/mastodon.install b/mastodon.install
index 3f3b602e3331..8543440cf41a 100644
--- a/mastodon.install
+++ b/mastodon.install
@@ -1,6 +1,10 @@
post_install() {
+ cd /var/lib/mastodon
+
echo "Setting ownership of mastodon files"
- chown mastodon:mastodon -R /var/lib/mastodon
+ chown mastodon:mastodon -R .
+ echo "Precompiling assets"
+ sudo -u mastodon RAILS_ENV=production bundle exec rails assets:precompile
echo "To setup Mastodon, enable and start PostgreSQL and Redis:
# systemctl enable --now postgresql redis
@@ -14,11 +18,12 @@ Finally, enable and start all the required services:
}
post_upgrade() {
- echo "Setting ownership of mastodon files"
- chown mastodon:mastodon -R /var/lib/mastodon
+ cd /var/lib/mastodon
- echo "To upgrade the database schema, run:
-# sudo -u mastodon RAILS_ENV=production bundle exec rails db:migrate
-To pre-compile assets, run:
-# sudo -u mastodon RAILS_ENV=production bundle exec rails assets:precompile"
+ echo "Setting ownership of mastodon files"
+ chown mastodon:mastodon -R .
+ echo "Upgrading database schema"
+ sudo -u mastodon RAILS_ENV=production bundle exec rails db:migrate
+ echo "Precompiling assets"
+ sudo -u mastodon RAILS_ENV=production bundle exec rails assets:precompile
}