summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2022-10-27 19:39:22 +0000
committerAnthony Wang2022-10-27 19:42:07 +0000
commit849e10aad328f441dabc94e2ae2f1ef62e44110e (patch)
tree4210b208420f49d192c25a221d635fec51934e7c
parent47b70b64beab47a70ccfbf297e2e334ed99c4007 (diff)
downloadaur-849e10aad328f441dabc94e2ae2f1ef62e44110e.tar.gz
Use Ruby psych 3 instead of 4
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86ab5fd0eb7f..e948e2dbbef6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mastodon
pkgdesc = Your self-hosted, globally interconnected microblogging community
pkgver = 3.5.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mastodon/mastodon
install = mastodon.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 296df17c6987..222cb0c091b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Anthony Wang <ta180m@proton.me>
+# Maintainer: Anthony Wang <a att exozy doot me>
# Contributor: ny-a <nyaarch64 at gmail dot com>
# Contributor: Daniel Moch <daniel@danielmoch.com>
# Contributor: Jean Lucas <jean@4ray.co>
@@ -6,7 +6,7 @@
pkgname=mastodon
pkgver=3.5.3
-pkgrel=1
+pkgrel=2
pkgdesc='Your self-hosted, globally interconnected microblogging community'
arch=(x86_64)
url=https://github.com/mastodon/mastodon
@@ -41,13 +41,13 @@ sha512sums=('9035184ead64b46f28630d8a5d57ae414b34a81604f7acb146ef56f7c76483fbb88
prepare() {
cd mastodon-$pkgver
- # Allow use of any bundler
- sed -i -e '/BUNDLED/,+1d' Gemfile.lock
+ echo "gem 'psych', '< 4'" >> Gemfile
}
build() {
cd mastodon-$pkgver
- bundle config set deployment 'true'
+ bundle config set --local path 'vendor/bundle'
+ bundle config unset deployment
bundle config set without 'development test'
bundle install -j$(getconf _NPROCESSORS_ONLN)
yarn install --pure-lockfile