summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2024-05-17 20:20:57 +0000
committerAnthony Wang2024-05-17 20:20:57 +0000
commit84db32927b30534afa1d12f7507b1b6c9d6e5173 (patch)
tree70e57b1a1545af19a3ba2ea3ac4ab26d47d2085e
parent5483245e260ada6245d51fa7b3e0dd306bae806e (diff)
downloadaur-84db32927b30534afa1d12f7507b1b6c9d6e5173.tar.gz
Add -Wno-incompatible-pointer-types to ignore cbor and posix-spawn errors
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf52149cb482..0dc538f05d71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,6 +47,8 @@ build() {
bundle config deployment 'true'
bundle config without 'development test'
bundle config with 'pam_authentication'
+ bundle config build.cbor --with-cflags="-Wno-incompatible-pointer-types"
+ bundle config build.posix-spawn --with-cflags="-Wno-incompatible-pointer-types"
bundle install -j$(getconf _NPROCESSORS_ONLN)
yarn install --pure-lockfile
}