summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-08-22 17:27:08 -0400
committerJean Lucas2018-08-22 17:27:17 -0400
commitf082f2349dfd5bcf731325a6ab705de9c59cd3d9 (patch)
treefc7054a6afb57ab06e7dcdf0a4e41a128eea85a7
parent955114a336431192b72f1cc57b3da752b0f8b7f6 (diff)
downloadaur-f082f2349dfd5bcf731325a6ab705de9c59cd3d9.tar.gz
Version bump to 2.4.4, move environment file to etc
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15d680b1ff04..c7c9fd6ed24a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 7 03:09:26 UTC 2018
+# Wed Aug 22 21:25:37 UTC 2018
pkgbase = mastodon
pkgdesc = Free software social network server based on ActivityPub and OStatus
- pkgver = 2.4.3
+ pkgver = 2.4.4
pkgrel = 1
url = https://joinmastodon.org
install = mastodon.install
@@ -22,12 +22,13 @@ pkgbase = mastodon
depends = ruby-bundler
depends = protobuf
conflicts = mastodon-git
- source = https://github.com/tootsuite/mastodon/archive/v2.4.3.tar.gz
+ backup = etc/mastodon/environment
+ source = https://github.com/tootsuite/mastodon/archive/v2.4.4.tar.gz
source = mastodon-web.service
source = mastodon-sidekiq.service
source = mastodon-streaming.service
source = mastodon.target
- sha512sums = 0e84dffef9e10e302e381cc09eb37103e1c000cf4ffd056f5860f7c84a769b3a0d7ebf6cac40aa461d1eb10c74bf3c5cfaa111a51b038cecbf96b3737b5d5ff5
+ sha512sums = b08ce705185164e4f84aa654084fcf5a3c40fa1bb77204721f23d80233cbd979e2a18a94a658d707db7ea5eae8654b9dc63c02b9d494c28ebcb36d925de6b440
sha512sums = 532929aeeda9a0ccf72de0695a3381547cc389344e1e67f05ef1d7ce5c1ad57278b647423bb52d4a87069ad85479452533fbe3786e5e5c4b62730c6ef72ff267
sha512sums = 603a7877288c762855a29fd2399d3ff7d218a7f1b7d6378cad7f30048cdbfe2a13f2ed2b5c94cb683bdcaead8cd47243e564a2ae70d7f21fa33f295c5396f4f7
sha512sums = 90a0761b7709659bec6f29c366c503fdd348226cbb585cf4f6eaa065854e2027d08ab3b352eb13ad7c0e327d662f13bc00fb4163ea0c583ef55b1795ab2e0b31
diff --git a/PKGBUILD b/PKGBUILD
index 8f5009222233..23bf49adf2bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=mastodon
-pkgver=2.4.3
+pkgver=2.4.4
pkgrel=1
pkgdesc='Free software social network server based on ActivityPub and OStatus'
arch=(i686 x86_64)
@@ -19,13 +19,14 @@ depends=(ffmpeg
protobuf)
makedepends=(yarn python2)
conflicts=(mastodon-git)
+backup=(etc/mastodon/environment)
install=mastodon.install
source=(https://github.com/tootsuite/mastodon/archive/v$pkgver.tar.gz
mastodon-web.service
mastodon-sidekiq.service
mastodon-streaming.service
mastodon.target)
-sha512sums=('0e84dffef9e10e302e381cc09eb37103e1c000cf4ffd056f5860f7c84a769b3a0d7ebf6cac40aa461d1eb10c74bf3c5cfaa111a51b038cecbf96b3737b5d5ff5'
+sha512sums=('b08ce705185164e4f84aa654084fcf5a3c40fa1bb77204721f23d80233cbd979e2a18a94a658d707db7ea5eae8654b9dc63c02b9d494c28ebcb36d925de6b440'
'532929aeeda9a0ccf72de0695a3381547cc389344e1e67f05ef1d7ce5c1ad57278b647423bb52d4a87069ad85479452533fbe3786e5e5c4b62730c6ef72ff267'
'603a7877288c762855a29fd2399d3ff7d218a7f1b7d6378cad7f30048cdbfe2a13f2ed2b5c94cb683bdcaead8cd47243e564a2ae70d7f21fa33f295c5396f4f7'
'90a0761b7709659bec6f29c366c503fdd348226cbb585cf4f6eaa065854e2027d08ab3b352eb13ad7c0e327d662f13bc00fb4163ea0c583ef55b1795ab2e0b31'
@@ -38,7 +39,9 @@ build() {
}
package() {
- install -d "$pkgdir"/var/lib
+ install -d "$pkgdir"{/var/lib,/etc/mastodon}
cp -a mastodon-$pkgver "$pkgdir"/var/lib/mastodon
+ ln -s /etc/mastodon/environment "$pkgdir"/var/lib/mastodon/.env
+ touch "$pkgdir"/etc/mastodon/environment
install -Dm 644 -t "$pkgdir"/usr/lib/systemd/system mastodon-{web,sidekiq,streaming}.service mastodon.target
}