summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2023-09-21 16:58:43 +0000
committerAnthony Wang2023-09-21 16:58:43 +0000
commitf7d382bf4c4d1ed63772687fb137c43424116d6f (patch)
treea21c1b65918c935c870ef963d09184ab883acff3
parent41c52451a80b4c0da255b7b6e40f4a252bacc480 (diff)
downloadaur-f7d382bf4c4d1ed63772687fb137c43424116d6f.tar.gz
upgpkg: mastodon 4.2.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a49d0cf5541..e771985e429b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mastodon
pkgdesc = Your self-hosted, globally interconnected microblogging community
- pkgver = 4.1.9
+ pkgver = 4.2.0
pkgrel = 1
url = https://github.com/mastodon/mastodon
install = mastodon.install
@@ -26,11 +26,11 @@ pkgbase = mastodon
depends = zlib
options = !strip
backup = etc/mastodon.conf
- source = https://github.com/mastodon/mastodon/archive/v4.1.9.tar.gz
+ source = https://github.com/mastodon/mastodon/archive/v4.2.0.tar.gz
source = mastodon.target
source = mastodon.sysusers.d
source = mastodon.tmpfiles.d
- sha512sums = 665d9861daed80c0c85c335207a768605f8110507464f7d5bb1b2030dce4420e9bbe70a54f0ceb95629cf7d7a548382591049e85c827c8e2f35eb0303607c12e
+ sha512sums = d754ae69598dd4b7d4dfeb5e6c69cda423043b859275b5e1373d9b41c1e8f985751806432c1d0c5e5d1b62b1469f653ccd991663180fca540e49129a27617d56
sha512sums = c9820c2a83d08bd5d842a78e924682db97ebd5c7291b682603ad30dafcdcc5816c13e717ad39554f042b9d9ed71ab902ce3f604952264a900a72612ee8060acb
sha512sums = 4ee4210bde391e6dc782cb7c14f2cb968c95ad541aa0efcf843a811f8cc5f0d1067ee3c8346bb412aa9fd1dd5a8bd05a4524df7dc4a106957009853dd237074a
sha512sums = 27c4eb01d462c525b59e5808a3b2501b63a34425752128388fbde82f7eb5944b20d2f8d8b1be8ed8adb165cab4cfb8e13f90215f20989ca671a0422ffa37001f
diff --git a/PKGBUILD b/PKGBUILD
index c6f5742223ab..0f036299f653 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Fredrick Brennan <copypaste@kittens.ph>
pkgname=mastodon
-pkgver=4.1.9
+pkgver=4.2.0
pkgrel=1
pkgdesc='Your self-hosted, globally interconnected microblogging community'
arch=(any)
@@ -36,23 +36,16 @@ source=(https://github.com/mastodon/mastodon/archive/v$pkgver.tar.gz
mastodon.target
mastodon.sysusers.d
mastodon.tmpfiles.d)
-sha512sums=('665d9861daed80c0c85c335207a768605f8110507464f7d5bb1b2030dce4420e9bbe70a54f0ceb95629cf7d7a548382591049e85c827c8e2f35eb0303607c12e'
+sha512sums=('d754ae69598dd4b7d4dfeb5e6c69cda423043b859275b5e1373d9b41c1e8f985751806432c1d0c5e5d1b62b1469f653ccd991663180fca540e49129a27617d56'
'c9820c2a83d08bd5d842a78e924682db97ebd5c7291b682603ad30dafcdcc5816c13e717ad39554f042b9d9ed71ab902ce3f604952264a900a72612ee8060acb'
'4ee4210bde391e6dc782cb7c14f2cb968c95ad541aa0efcf843a811f8cc5f0d1067ee3c8346bb412aa9fd1dd5a8bd05a4524df7dc4a106957009853dd237074a'
'27c4eb01d462c525b59e5808a3b2501b63a34425752128388fbde82f7eb5944b20d2f8d8b1be8ed8adb165cab4cfb8e13f90215f20989ca671a0422ffa37001f')
-prepare() {
- cd mastodon-$pkgver
-
- echo "gem 'psych', '< 4'" >> Gemfile
- echo "gem 'erb'" >> Gemfile
-}
-
build() {
cd mastodon-$pkgver
- bundle config set --local path 'vendor/bundle'
- bundle config unset deployment
- bundle config set without 'development test'
+ mkdir -p .git # Fix husky error
+ bundle config deployment 'true'
+ bundle config without 'development test'
bundle install -j$(getconf _NPROCESSORS_ONLN)
yarn install --pure-lockfile
}